lkml.org 
[lkml]   [2021]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectRe: [PATCH v4 04/18] KVM: arm64: selftests: Introduce ARM64_SYS_KVM_REG
    Hi Raghu,

    On Thu, Sep 09, 2021 at 01:38:04AM +0000, Raghavendra Rao Ananta wrote:
    > With the inclusion of sysreg.h, that brings in system register
    > encodings, it would be redundant to re-define register encodings
    > again in processor.h to use it with ARM64_SYS_REG for the KVM
    > functions such as set_reg() or get_reg(). Hence, add helper macro,
    > ARM64_SYS_KVM_REG, that converts SYS_* definitions in sysreg.h
    > into ARM64_SYS_REG definitions.
    >
    > Signed-off-by: Raghavendra Rao Ananta <rananta@google.com>
    > ---
    > .../selftests/kvm/include/aarch64/processor.h | 14 ++++++++++++++
    > 1 file changed, 14 insertions(+)
    >
    > diff --git a/tools/testing/selftests/kvm/include/aarch64/processor.h b/tools/testing/selftests/kvm/include/aarch64/processor.h
    > index bed4ffa70905..ac8b63f8aab7 100644
    > --- a/tools/testing/selftests/kvm/include/aarch64/processor.h
    > +++ b/tools/testing/selftests/kvm/include/aarch64/processor.h
    > @@ -26,6 +26,20 @@
    >
    > #define ID_AA64DFR0_EL1 3, 0, 0, 5, 0
    >
    > +/*
    > + * ARM64_SYS_KVM_REG(sys_reg_id): Helper macro to convert
    > + * SYS_* register definitions in sysreg.h to use in KVM
    > + * calls such as get_reg() and set_reg().
    > + */
    > +#define ARM64_SYS_KVM_REG(sys_reg_id) \

    nit: KVM_ARM64_SYS_REG() perhaps? Dunno which is more readable.

    > +({ \
    > + ARM64_SYS_REG(sys_reg_Op0(sys_reg_id), \
    > + sys_reg_Op1(sys_reg_id), \
    > + sys_reg_CRn(sys_reg_id), \
    > + sys_reg_CRm(sys_reg_id), \
    > + sys_reg_Op2(sys_reg_id)); \
    > +})
    > +

    Could you also switch all current users of ARM64_SYS_REG() in the KVM
    selftests directory in this commit? You can also drop the system
    register encodings defined in processor.h

    --
    Thanks,
    Oliver
    \
     
     \ /
      Last update: 2021-09-09 05:02    [W:3.206 / U:0.140 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site