lkml.org 
[lkml]   [2021]   [Sep]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [RFC PATCH 2/8] mm/madvise: remove unnecessary check on madvise_dontneed_free()
    From
    Date


    > On Sep 27, 2021, at 2:11 AM, Kirill A. Shutemov <kirill@shutemov.name> wrote:
    >
    > On Sun, Sep 26, 2021 at 09:12:53AM -0700, Nadav Amit wrote:
    >> From: Nadav Amit <namit@vmware.com>
    >>
    >> madvise_dontneed_free() is called only from madvise_vma() and the
    >> behavior is always either MADV_FREE or MADV_DONTNEED. There is no need
    >> to check again in madvise_dontneed_free() if the behavior is any
    >> different.
    >
    > So what. The check is free. Compiler should be clever enough to eliminate
    > the additional check. If there's a new MADV_DONTNEED flavour, the change
    > would have to be effectively reverted.
    >
    > NAK.

    I hate bikeshedding, but I will take the bait, since I see no
    reason for this NAK.

    I do not know what future change you have in mind in which quietly
    failing in madvise_dontneed_free() would be the right behavior.

    If the current code is presumed to be more “robust” against future
    changes since there is an additional check, I would argue that this
    is not the case: failing silently on a code-path that should never
    run is not the right thing to do.

    Having redundant checks that are not documented as such do not make
    the code more readable or maintainable.

    Having said that, if you want, I can turn this condition into
    WARN_ON_ONCE() or VM_BUG_ON(), although I really see no reason to
    do so.

    [ You might just as well add a default statement to the switch in
    madvise_behavior(), which BTW would have been much more reasonable,
    but only if it does not fail silently as the one we discuss. ]

    Note that I made this change not out of boredom, but because I
    needed to change this piece of code later for TLB batching. I
    did not want to sneak this change in another patch or to leave
    this confusing code. Anyhow, I wasted enough time on this
    trivial patch.

    \
     
     \ /
      Last update: 2021-09-27 13:06    [W:3.560 / U:1.044 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site