lkml.org 
[lkml]   [2021]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/2] drm/msm/dpu: Fix timeout issues on command mode panels
From
Date
Il 10/09/21 23:48, Marijn Suijten ha scritto:
> Hi Angelo!
>
> On 2021-09-01 19:43:47, AngeloGioacchino Del Regno wrote:
>> In function dpu_encoder_phys_cmd_wait_for_commit_done we are always
>> checking if the relative CTL is started by waiting for an interrupt
>> to fire: it is fine to do that, but then sometimes we call this
>> function while the CTL is up and has never been put down, but that
>> interrupt gets raised only when the CTL gets a state change from
>> 0 to 1 (disabled to enabled), so we're going to wait for something
>> that will never happen on its own.
>>
>> Solving this while avoiding to restart the CTL is actually possible
>> and can be done by just checking if it is already up and running
>> when the wait_for_commit_done function is called: in this case, so,
>> if the CTL was already running, we can say that the commit is done
>> if the command transmission is complete (in other terms, if the
>> interface has been flushed).
>>
>> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@somainline.org>
>> ---
>> drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c | 3 +++
>> 1 file changed, 3 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c
>> index aa01698d6b25..b5b1b555ac4e 100644
>> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c
>> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c
>> @@ -682,6 +682,9 @@ static int dpu_encoder_phys_cmd_wait_for_commit_done(
>> if (!dpu_encoder_phys_cmd_is_master(phys_enc))
>> return 0;
>>
>> + if (phys_enc->hw_ctl->ops.is_started)
>> + return dpu_encoder_phys_cmd_wait_for_tx_complete(phys_enc);
>
> In the previous commit you introduced is_started to the ops struct as
> function pointer, and you probably intend to call it here instead of
> just checking whether it might be NULL.
>
> As far as I remember this was also the reason for previously mentioning
> that it was faulty and required a v2 in:
> https://lore.kernel.org/linux-arm-msm/bdc67afc-3736-5497-c43f-5165c55e0354@somainline.org/
>
> Thanks!
>
> - Marijn
>

Ugh. I've pulled this from the wrong tree.
Sending a v2 asap.

>> +
>> return _dpu_encoder_phys_cmd_wait_for_ctl_start(phys_enc);
>> }
>>
>> --
>> 2.32.0
>>

\
 
 \ /
  Last update: 2021-09-11 18:36    [W:0.196 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site