lkml.org 
[lkml]   [2021]   [Aug]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH -next v3] nbd: add the check to prevent overflow in __nbd_ioctl()
From
Date
On 8/3/21 10:12 PM, Baokun Li wrote:
> If user specify a large enough value of NBD blocks option, it may trigger
> signed integer overflow which may lead to nbd->config->bytesize becomes a
> large or small value, zero in particular.
>
> UBSAN: Undefined behaviour in drivers/block/nbd.c:325:31
> signed integer overflow:
> 1024 * 4611686155866341414 cannot be represented in type 'long long int'
> [...]
> Call trace:
> [...]
> handle_overflow+0x188/0x1dc lib/ubsan.c:192
> __ubsan_handle_mul_overflow+0x34/0x44 lib/ubsan.c:213
> nbd_size_set drivers/block/nbd.c:325 [inline]
> __nbd_ioctl drivers/block/nbd.c:1342 [inline]
> nbd_ioctl+0x998/0xa10 drivers/block/nbd.c:1395
> __blkdev_driver_ioctl block/ioctl.c:311 [inline]
> [...]
>
> Although it is not a big deal, still silence the UBSAN by limit
> the input value.
>
> Reported-by: Hulk Robot <hulkci@huawei.com>
> Signed-off-by: Baokun Li <libaokun1@huawei.com>
> ---
> V1->V2:
> Use check_mul_overflow().
> V2->V3:
> The check_mul_overflow function requires the same input parameter type.
>
> drivers/block/nbd.c | 8 ++++++--
> 1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/block/nbd.c b/drivers/block/nbd.c
> index c38317979f74..5a42b838d26c 100644
> --- a/drivers/block/nbd.c
> +++ b/drivers/block/nbd.c
> @@ -1384,6 +1384,7 @@ static int __nbd_ioctl(struct block_device *bdev, struct nbd_device *nbd,
> unsigned int cmd, unsigned long arg)
> {
> struct nbd_config *config = nbd->config;
> + loff_t bytesize;
>
> switch (cmd) {
> case NBD_DISCONNECT:
> @@ -1398,8 +1399,11 @@ static int __nbd_ioctl(struct block_device *bdev, struct nbd_device *nbd,
> case NBD_SET_SIZE:
> return nbd_set_size(nbd, arg, config->blksize);
> case NBD_SET_SIZE_BLOCKS:
> - return nbd_set_size(nbd, arg * config->blksize,
> - config->blksize);
> + if (unlikely(check_mul_overflow((loff_t)arg,
> + config->blksize,
> + &bytesize)))
> + return -EINVAL;
> + return nbd_set_size(nbd, bytesize, config->blksize);

The unlikely isn't needed here, just makes it harder to read the thing, drop it
and then you can add

Reviewed-by: Josef Bacik <josef@toxicpanda.com>

Thanks,

Josef

\
 
 \ /
  Last update: 2021-08-13 17:55    [W:0.062 / U:0.328 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site