lkml.org 
[lkml]   [2021]   [Jul]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/4] mfd: rn5t618: Add of compatibles for ADC and power
On Sat, 03 Jul 2021, Jonathan Cameron wrote:

> On Sat, 3 Jul 2021 10:42:22 +0200
> Andreas Kemnade <andreas@kemnade.info> wrote:
>
> > This allows having devicetree nodes for the subdevices.
> >
> > Signed-off-by: Andreas Kemnade <andreas@kemnade.info>
> > ---
> > drivers/mfd/rn5t618.c | 6 ++++--
> > 1 file changed, 4 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/mfd/rn5t618.c b/drivers/mfd/rn5t618.c
> > index 384acb459427..b916c7471ca3 100644
> > --- a/drivers/mfd/rn5t618.c
> > +++ b/drivers/mfd/rn5t618.c
> > @@ -24,8 +24,10 @@ static const struct mfd_cell rn5t618_cells[] = {
> > };
> >
> > static const struct mfd_cell rc5t619_cells[] = {
> > - { .name = "rn5t618-adc" },
> > - { .name = "rn5t618-power" },
> > + { .name = "rn5t618-adc",
> > + .of_compatible = "ricoh,rc5t619-adc" },
>
> Odd to have a name of 618 and a compatible of 619. Why?
> Definitely deserves a comment if this is necessary for some reason!

Actually this is the norm. We have lots of drivers named after the
*first* device they supported before expansion.

> > + { .name = "rn5t618-power",
> > + .of_compatible = "ricoh,rc5t619-power" },
> > { .name = "rn5t618-regulator" },
> > { .name = "rc5t619-rtc" },
> > { .name = "rn5t618-wdt" },
>

--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog

\
 
 \ /
  Last update: 2021-07-05 09:37    [W:1.806 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site