lkml.org 
[lkml]   [2021]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/4] mfd: rn5t618: Add of compatibles for ADC and power
Hi,

On Sat, 3 Jul 2021 17:04:05 +0100
Jonathan Cameron <jic23@kernel.org> wrote:

> On Sat, 3 Jul 2021 10:42:22 +0200
> Andreas Kemnade <andreas@kemnade.info> wrote:
>
> > This allows having devicetree nodes for the subdevices.
> >
> > Signed-off-by: Andreas Kemnade <andreas@kemnade.info>
> > ---
> > drivers/mfd/rn5t618.c | 6 ++++--
> > 1 file changed, 4 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/mfd/rn5t618.c b/drivers/mfd/rn5t618.c
> > index 384acb459427..b916c7471ca3 100644
> > --- a/drivers/mfd/rn5t618.c
> > +++ b/drivers/mfd/rn5t618.c
> > @@ -24,8 +24,10 @@ static const struct mfd_cell rn5t618_cells[] = {
> > };
> >
> > static const struct mfd_cell rc5t619_cells[] = {
> > - { .name = "rn5t618-adc" },
> > - { .name = "rn5t618-power" },
> > + { .name = "rn5t618-adc",
> > + .of_compatible = "ricoh,rc5t619-adc" },
>
> Odd to have a name of 618 and a compatible of 619. Why?
> Definitely deserves a comment if this is necessary for some reason!
>
Background of this whole thing:
Both RN5T618 and RC5T619 have an ADC. I would expect the driver to work
for both but I cannot prove that. No RN5T618 here to test. Maybe it
requires some quirks, probably not. The only hint I have is that
a) I use register definitions added to the kernel for RN5T618 support
b) public datasheets looks same regarding the ADC.
c) out-of-tree code for the RN5T618 does not give a clear picture, it
shows no differences but is not complete enough to judge.

To avoid introducing untested things, I am only adding it to the
rc5t619_cell list. I would really hope that someone does some rn5t618
tests... Because everything else which is both for the RN5T618 and
RC5T619 uses rn5t618 as a name, I continued that practise.

The subdevice driver also gets the information whether it is a rn5t618
or rc5t619 via rn5t618->variant, so it can handle things.

> > + { .name = "rn5t618-power",
> > + .of_compatible = "ricoh,rc5t619-power" },

Similar situation here.

> > { .name = "rn5t618-regulator" },
> > { .name = "rc5t619-rtc" },
and this one definitively only exists in the rc5t619.

> > { .name = "rn5t618-wdt" },
>
>

Regards,
Andreas

\
 
 \ /
  Last update: 2021-07-03 18:32    [W:0.096 / U:0.824 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site