lkml.org 
[lkml]   [2021]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 3/4] staging: sm750fb: Rename vCursor to v_cursor in lynxfb_crtc
Date
The struct lynxfb_crtc has a member named vCursor. This name is
CamelCase and is frowned upon. This commit renames it to v_cursor
and makes the necessary changes for the module to build.

This change also fixes the following checkpatch CHECK:

CHECK: Avoid CamelCase: <vCursor>
135: FILE: sm750.h:135:
+ unsigned char __iomem *vCursor; /* virtual address of cursor */
Signed-off-by: Benjamin Philip <benjamin.philip495@gmail.com>
---
drivers/staging/sm750fb/sm750.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
index 4093d5e898c6..8952154739ac 100644
--- a/drivers/staging/sm750fb/sm750.h
+++ b/drivers/staging/sm750fb/sm750.h
@@ -132,7 +132,7 @@ struct lynx_cursor {
};

struct lynxfb_crtc {
- unsigned char __iomem *vCursor; /* virtual address of cursor */
+ unsigned char __iomem *v_cursor; /* virtual address of cursor */
unsigned char __iomem *vScreen; /* virtual address of on_screen */
int o_cursor; /* cursor address offset in vidmem */
int o_screen; /* onscreen address offset in vidmem */
--
2.31.1
\
 
 \ /
  Last update: 2021-07-27 21:21    [W:0.255 / U:0.164 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site