lkml.org 
[lkml]   [2021]   [Jul]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/6] iio/adc: ingenic: rename has_aux2 to has_aux_md
Hi Christophe,

Le mer., juil. 21 2021 at 12:53:12 +0200, citral23
<cbranchereau@gmail.com> a écrit :
> The purpose of this property is to set the AUX_MD bits if true, no to
> describe the hardware.
> Rename it to a more appropriate name.

You could add that this change is needed to support the JZ4760 which
has three AUX channels.

> Signed-off-by: Christophe Branchereau <cbranchereau@gmail.com>

Reviewed-by: Paul Cercueil <paul@crapouillou.net>

Cheers,
-Paul

> ---
> drivers/iio/adc/ingenic-adc.c | 10 +++++-----
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/iio/adc/ingenic-adc.c
> b/drivers/iio/adc/ingenic-adc.c
> index 34c03a264f74..40f2d8c2cf72 100644
> --- a/drivers/iio/adc/ingenic-adc.c
> +++ b/drivers/iio/adc/ingenic-adc.c
> @@ -92,7 +92,7 @@ struct ingenic_adc_soc_data {
> const int *battery_scale_avail;
> size_t battery_scale_avail_size;
> unsigned int battery_vref_mode: 1;
> - unsigned int has_aux2: 1;
> + unsigned int has_aux_md: 1;
> const struct iio_chan_spec *channels;
> unsigned int num_channels;
> int (*init_clk_div)(struct device *dev, struct ingenic_adc *adc);
> @@ -506,7 +506,7 @@ static const struct ingenic_adc_soc_data
> jz4725b_adc_soc_data = {
> .battery_scale_avail = jz4725b_adc_battery_scale_avail,
> .battery_scale_avail_size =
> ARRAY_SIZE(jz4725b_adc_battery_scale_avail),
> .battery_vref_mode = true,
> - .has_aux2 = false,
> + .has_aux_md = false,
> .channels = jz4740_channels,
> .num_channels = ARRAY_SIZE(jz4740_channels),
> .init_clk_div = jz4725b_adc_init_clk_div,
> @@ -520,7 +520,7 @@ static const struct ingenic_adc_soc_data
> jz4740_adc_soc_data = {
> .battery_scale_avail = jz4740_adc_battery_scale_avail,
> .battery_scale_avail_size =
> ARRAY_SIZE(jz4740_adc_battery_scale_avail),
> .battery_vref_mode = true,
> - .has_aux2 = false,
> + .has_aux_md = false,
> .channels = jz4740_channels,
> .num_channels = ARRAY_SIZE(jz4740_channels),
> .init_clk_div = NULL, /* no ADCLK register on JZ4740 */
> @@ -534,7 +534,7 @@ static const struct ingenic_adc_soc_data
> jz4770_adc_soc_data = {
> .battery_scale_avail = jz4770_adc_battery_scale_avail,
> .battery_scale_avail_size =
> ARRAY_SIZE(jz4770_adc_battery_scale_avail),
> .battery_vref_mode = false,
> - .has_aux2 = true,
> + .has_aux_md = true,
> .channels = jz4770_channels,
> .num_channels = ARRAY_SIZE(jz4770_channels),
> .init_clk_div = jz4770_adc_init_clk_div,
> @@ -581,7 +581,7 @@ static int ingenic_adc_read_chan_info_raw(struct
> iio_dev *iio_dev,
>
> /* We cannot sample AUX/AUX2 in parallel. */
> mutex_lock(&adc->aux_lock);
> - if (adc->soc_data->has_aux2 && engine == 0) {
> + if (adc->soc_data->has_aux_md && engine == 0) {
> bit = BIT(chan->channel == INGENIC_ADC_AUX2);
> ingenic_adc_set_config(adc, JZ_ADC_REG_CFG_AUX_MD, bit);
> }
> --
> 2.30.2
>


\
 
 \ /
  Last update: 2021-07-21 19:47    [W:0.842 / U:0.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site