lkml.org 
[lkml]   [2021]   [Jul]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 0/3] Make PMD_ORDER generically available
From
Date
On 7/15/21 3:46 PM, Matthew Wilcox (Oracle) wrote:
> These three architectures each define PMD_ORDER to mean "the order of
> an allocation for a PMD table", but logically PMD_ORDER should be the
> order of a PMD allocation, ie (PMD_SHIFT - PAGE_SHIFT) as DAX defines it.

Some architectures do have PGD_ORDER, PUD_ORDER and PTE_ORDER as well.
If you rename PMD_ORDER, IMHO the others should be renamed too.

Why not simply rename "PMD_ORDER" in fs/dax.c to e.g.
#define DAX_PMD_SHIFT (PMD_SHIFT - PAGE_SHIFT)
and use that inside the dax filesystem code?

Helge

> Could each architecture maintainer please apply the appropriate patch
> to their respective trees?
>
> Matthew Wilcox (Oracle) (3):
> arm: Rename PMD_ORDER to PMD_TABLE_ORDER
> mips: Rename PMD_ORDER to PMD_TABLE_ORDER
> parisc: Rename PMD_ORDER to PMD_TABLE_ORDER
>
> arch/arm/kernel/head.S | 34 +++++++++++++++---------------
> arch/mips/include/asm/pgalloc.h | 2 +-
> arch/mips/include/asm/pgtable-32.h | 2 +-
> arch/mips/include/asm/pgtable-64.h | 18 ++++++++--------
> arch/mips/kernel/asm-offsets.c | 2 +-
> arch/parisc/include/asm/pgalloc.h | 6 +++---
> arch/parisc/include/asm/pgtable.h | 4 ++--
> arch/parisc/mm/init.c | 4 ++--
> 8 files changed, 36 insertions(+), 36 deletions(-)
>

\
 
 \ /
  Last update: 2021-07-15 18:30    [W:0.071 / U:0.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site