lkml.org 
[lkml]   [2021]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v3 10/19] auxdisplay: ht16k33: Use HT16K33_FB_SIZE in ht16k33_initialize()
    Date
    Use the existing HT16K33_FB_SIZE definition instead of open-coding the
    same calculation using an hardcoded value.
    While at it, restore reverse Christmas tree variable declaration order.

    Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
    Acked-by: Robin van der Gracht <robin@protonic.nl>
    ---
    v3:
    - No changes,

    v2:
    - Add Acked-by.
    ---
    drivers/auxdisplay/ht16k33.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/drivers/auxdisplay/ht16k33.c b/drivers/auxdisplay/ht16k33.c
    index 2b630e194570f6e5..99daf1974980b435 100644
    --- a/drivers/auxdisplay/ht16k33.c
    +++ b/drivers/auxdisplay/ht16k33.c
    @@ -168,9 +168,9 @@ static void ht16k33_fb_update(struct work_struct *work)

    static int ht16k33_initialize(struct ht16k33_priv *priv)
    {
    + uint8_t data[HT16K33_FB_SIZE];
    uint8_t byte;
    int err;
    - uint8_t data[HT16K33_MATRIX_LED_MAX_COLS * 2];

    /* Clear RAM (8 * 16 bits) */
    memset(data, 0, sizeof(data));
    --
    2.25.1
    \
     
     \ /
      Last update: 2021-07-14 17:13    [W:4.177 / U:0.016 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site