lkml.org 
[lkml]   [2021]   [Jul]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v1 5/6] software nodes: Split software_node_notify()
On Mon, Jul 12, 2021 at 07:27:12PM +0200, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>
> Split software_node_notify_remove) out of software_node_notify()
> and make device_platform_notify() call the latter on device addition
> and the former on device removal.
>
> While at it, put the headers of the above functions into base.h,
> because they don't need to be present in a global header file.
>
> No intentional functional impact.
>
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> ---
> drivers/base/base.h | 3 ++
> drivers/base/core.c | 9 +++---
> drivers/base/swnode.c | 61 ++++++++++++++++++++++++-----------------------
> include/linux/property.h | 2 -
> 4 files changed, 39 insertions(+), 36 deletions(-)
>
> Index: linux-pm/drivers/base/swnode.c
> ===================================================================
> --- linux-pm.orig/drivers/base/swnode.c
> +++ linux-pm/drivers/base/swnode.c
> @@ -11,6 +11,8 @@
> #include <linux/property.h>
> #include <linux/slab.h>
>
> +#include "base.h"
> +
> struct swnode {
> struct kobject kobj;
> struct fwnode_handle fwnode;
> @@ -1053,7 +1055,7 @@ int device_add_software_node(struct devi
> * balance.
> */
> if (device_is_registered(dev))
> - software_node_notify(dev, KOBJ_ADD);
> + software_node_notify(dev);

Should this now be called "software_node_notify_add()" to match up with:

> if (device_is_registered(dev))
> - software_node_notify(dev, KOBJ_REMOVE);
> + software_node_notify_remove(dev);

The other being called "_remove"?

Makes it more obvious to me :)

thanks,

greg k-h

\
 
 \ /
  Last update: 2021-07-12 20:04    [W:0.168 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site