lkml.org 
[lkml]   [2021]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v7 8/8] PCI: Change the type of probe argument in reset functions
Date
On Tue, Jun 08, 2021 at 11:18:57AM +0530, Amey Narkhede wrote:
> Introduce a new enum pci_reset_mode_t to make the context of probe argument
> in reset functions clear and the code easier to read.
> Change the type of probe argument in functions which implement reset
> methods from int to pci_reset_mode_t to make the intent clear.
>
> Add a new line in return statement of pci_reset_bus_function().
>
> Suggested-by: Alex Williamson <alex.williamson@redhat.com>
> Suggested-by: Krzysztof Wilczyński <kw@linux.com>
> Signed-off-by: Amey Narkhede <ameynarkhede03@gmail.com>

Reviewed-by: Raphael Norwitz <raphael.norwitz@nutanix.com>

> ---
> drivers/crypto/cavium/nitrox/nitrox_main.c | 2 +-
> .../ethernet/cavium/liquidio/lio_vf_main.c | 2 +-
> drivers/pci/hotplug/pciehp.h | 2 +-
> drivers/pci/hotplug/pciehp_hpc.c | 4 +-
> drivers/pci/pci-acpi.c | 10 ++-
> drivers/pci/pci.c | 85 ++++++++++++-------
> drivers/pci/pci.h | 12 +--
> drivers/pci/pcie/aer.c | 2 +-
> drivers/pci/quirks.c | 37 ++++----
> include/linux/pci.h | 8 +-
> include/linux/pci_hotplug.h | 2 +-
> 11 files changed, 101 insertions(+), 65 deletions(-)
\
 
 \ /
  Last update: 2021-06-09 23:40    [W:0.276 / U:1.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site