lkml.org 
[lkml]   [2021]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch V3 40/66] x86/fpu: Rename and sanitize fpu__save/copy()
On Fri, Jun 18, 2021 at 04:19:03PM +0200, Thomas Gleixner wrote:
> Both functions are misnomed.

"Both function names are a misnomer." or simply
"Both function are not named optimally."

> -int fpu__copy(struct task_struct *dst, struct task_struct *src)
> +/* Clone current's FPU state on fork */
> +int fpu_clone(struct task_struct *dst)
> {
> + struct fpu *src_fpu = &current->thread.fpu;
> struct fpu *dst_fpu = &dst->thread.fpu;
> - struct fpu *src_fpu = &src->thread.fpu;
>
> + /* The new task's FPU state cannot be valid in the hardware. */
> dst_fpu->last_cpu = -1;
>
> if (!static_cpu_has(X86_FEATURE_FPU))

cpu_feature_enabled

while at it.

Regardless, looks nice.

Reviewed-by: Borislav Petkov <bp@suse.de>

--
Regards/Gruss,
Boris.

SUSE Software Solutions Germany GmbH, GF: Felix Imendörffer, HRB 36809, AG Nürnberg

\
 
 \ /
  Last update: 2021-06-22 15:52    [W:0.576 / U:2.448 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site