lkml.org 
[lkml]   [2021]   [Jun]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 08/27] mm: Introduce zap_details.zap_flags
Date
On Friday, 28 May 2021 6:21:30 AM AEST Peter Xu wrote:
> Instead of trying to introduce one variable for every new zap_details fields,
> let's introduce a flag so that it can start to encode true/false informations.
>
> Let's start to use this flag first to clean up the only check_mapping variable.
> Firstly, the name "check_mapping" implies this is a "boolean", but actually it
> stores the mapping inside, just in a way that it won't be set if we don't want
> to check the mapping.
>
> To make things clearer, introduce the 1st zap flag ZAP_FLAG_CHECK_MAPPING, so
> that we only check against the mapping if this bit set. At the same time, we
> can rename check_mapping into zap_mapping and set it always.
>
> Since at it, introduce another helper zap_check_mapping_skip() and use it in
> zap_pte_range() properly.
>
> Some old comments have been removed in zap_pte_range() because they're
> duplicated, and since now we're with ZAP_FLAG_CHECK_MAPPING flag, it'll be very
> easy to grep this information by simply grepping the flag.
>
> It'll also make life easier when we want to e.g. pass in zap_flags into the
> callers like unmap_mapping_pages() (instead of adding new booleans besides the
> even_cows parameter).
>
> Signed-off-by: Peter Xu <peterx@redhat.com>
> ---
> include/linux/mm.h | 19 ++++++++++++++++++-
> mm/memory.c | 31 ++++++++-----------------------
> 2 files changed, 26 insertions(+), 24 deletions(-)
>
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index db155be8e66c..52d3ef2ed753 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -1721,13 +1721,30 @@ static inline bool can_do_mlock(void) { return false; }
> extern int user_shm_lock(size_t, struct user_struct *);
> extern void user_shm_unlock(size_t, struct user_struct *);
>
> +/* Whether to check page->mapping when zapping */
> +#define ZAP_FLAG_CHECK_MAPPING BIT(0)
> +
> /*
> * Parameter block passed down to zap_pte_range in exceptional cases.
> */
> struct zap_details {
> - struct address_space *check_mapping; /* Check page->mapping if set */
> + struct address_space *zap_mapping;
> + unsigned long zap_flags;
> };
>
> +/* Return true if skip zapping this page, false otherwise */
> +static inline bool
> +zap_check_mapping_skip(struct zap_details *details, struct page *page)
> +{
> + if (!details || !page)
> + return false;
> +
> + if (!(details->zap_flags & ZAP_FLAG_CHECK_MAPPING))
> + return false;
> +
> + return details->zap_mapping != page_rmapping(page);

I doubt this matters in practice, but there is a slight behaviour change
here that might be worth checking. Previously this check was equivalent
to:

details->zap_mapping && details->zap_mapping != page_rmapping(page)

Otherwise I think this looks good.

> +}
> +
> struct page *vm_normal_page(struct vm_area_struct *vma, unsigned long addr,
> pte_t pte);
> struct page *vm_normal_page_pmd(struct vm_area_struct *vma, unsigned long addr,
> diff --git a/mm/memory.c b/mm/memory.c
> index 27cf8a6375c6..c9dc4e9e05b5 100644
> --- a/mm/memory.c
> +++ b/mm/memory.c
> @@ -1330,16 +1330,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb,
> struct page *page;
>
> page = vm_normal_page(vma, addr, ptent);
> - if (unlikely(details) && page) {
> - /*
> - * unmap_shared_mapping_pages() wants to
> - * invalidate cache without truncating:
> - * unmap shared but keep private pages.
> - */
> - if (details->check_mapping &&
> - details->check_mapping != page_rmapping(page))
> - continue;
> - }
> + if (unlikely(zap_check_mapping_skip(details, page)))
> + continue;
> ptent = ptep_get_and_clear_full(mm, addr, pte,
> tlb->fullmm);
> tlb_remove_tlb_entry(tlb, pte, addr);
> @@ -1372,17 +1364,8 @@ static unsigned long zap_pte_range(struct mmu_gather *tlb,
> is_device_exclusive_entry(entry)) {
> struct page *page = pfn_swap_entry_to_page(entry);
>
> - if (unlikely(details && details->check_mapping)) {
> - /*
> - * unmap_shared_mapping_pages() wants to
> - * invalidate cache without truncating:
> - * unmap shared but keep private pages.
> - */
> - if (details->check_mapping !=
> - page_rmapping(page))
> - continue;
> - }
> -
> + if (unlikely(zap_check_mapping_skip(details, page)))
> + continue;
> pte_clear_not_present_full(mm, addr, pte, tlb->fullmm);
> rss[mm_counter(page)]--;
>
> @@ -3345,9 +3328,11 @@ void unmap_mapping_pages(struct address_space *mapping, pgoff_t start,
> pgoff_t nr, bool even_cows)
> {
> pgoff_t first_index = start, last_index = start + nr - 1;
> - struct zap_details details = { };
> + struct zap_details details = { .zap_mapping = mapping };
> +
> + if (!even_cows)
> + details.zap_flags |= ZAP_FLAG_CHECK_MAPPING;
>
> - details.check_mapping = even_cows ? NULL : mapping;
> if (last_index < first_index)
> last_index = ULONG_MAX;
>
>




\
 
 \ /
  Last update: 2021-06-21 14:10    [W:0.611 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site