lkml.org 
[lkml]   [2021]   [Jun]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] fuse: use DIV_ROUND_UP helper macro for calculations
From
Date
ping ...

On 2021/5/25 15:40, Wu Bo wrote:
> From: Wu Bo <wubo40@huawei.com>
>
> Replace open coded divisor calculations with the DIV_ROUND_UP kernel
> macro for better readability.
>
> Signed-off-by: Wu Bo <wubo40@huawei.com>
> ---
> fs/fuse/file.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/fuse/file.c b/fs/fuse/file.c
> index 09ef2a4..62443eb 100644
> --- a/fs/fuse/file.c
> +++ b/fs/fuse/file.c
> @@ -1405,7 +1405,7 @@ static int fuse_get_user_pages(struct fuse_args_pages *ap, struct iov_iter *ii,
> nbytes += ret;
>
> ret += start;
> - npages = (ret + PAGE_SIZE - 1) / PAGE_SIZE;
> + npages = DIV_ROUND_UP(ret, PAGE_SIZE);
>
> ap->descs[ap->num_pages].offset = start;
> fuse_page_descs_length_init(ap->descs, ap->num_pages, npages);
>

\
 
 \ /
  Last update: 2021-06-01 08:11    [W:0.046 / U:3.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site