lkml.org 
[lkml]   [2021]   [May]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 02/49] staging: sm750fb: Rename dviInit to dvi_init and update param names
On Tue, Apr 06, 2021 at 11:36:01PM -0700, Pavle Rohalj wrote:
> Fix "Avoid CamelCase" checkpatch.pl checks for the function dviInit and
> its parameter names in ddk750_dvi.h.
>
> Signed-off-by: Pavle Rohalj <pavle.rohalj@gmail.com>
> ---
> drivers/staging/sm750fb/ddk750_dvi.c | 2 +-
> drivers/staging/sm750fb/ddk750_dvi.h | 20 ++++++++++----------
> 2 files changed, 11 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/ddk750_dvi.c b/drivers/staging/sm750fb/ddk750_dvi.c
> index db19bf732482..943cbcafcffa 100644
> --- a/drivers/staging/sm750fb/ddk750_dvi.c
> +++ b/drivers/staging/sm750fb/ddk750_dvi.c
> @@ -30,7 +30,7 @@ static struct dvi_ctrl_device dcft_supported_dvi_controller[] = {
> #endif
> };
>
> -int dviInit(unsigned char edge_select,
> +int dvi_init(unsigned char edge_select,
> unsigned char bus_select,
> unsigned char dual_edge_clk_select,
> unsigned char hsync_enable,

The fact that you were able to change this without changing any callers
suggests that this is not used. In that case, just delete it instead
of renaming it.

regards,
dan carpenter

\
 
 \ /
  Last update: 2021-05-08 11:45    [W:0.519 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site