lkml.org 
[lkml]   [2021]   [May]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH] Raise the minimum GCC version to 5.2
    From
    Date


    Le 01/05/2021 à 17:15, Masahiro Yamada a écrit :
    > The current minimum GCC version is 4.9 except ARCH=arm64 requiring
    > GCC 5.1.
    >
    > When we discussed last time, we agreed to raise the minimum GCC version
    > to 5.1 globally. [1]
    >
    > I'd like to propose GCC 5.2 to clean up arch/powerpc/Kconfig as well.

    One point I missed when I saw your patch first time, but I realised during the discussion:

    Up to 4.9, GCC was numbered with 3 digits, we had 4.8.0, 4.8.1, ... 4.8.5, 4.9.0, 4.9.1, .... 4.9.4

    Then starting at 5, GCC switched to a 2 digits scheme, with 5.0, 5.1, 5.2, ... 5.5

    So, that is not GCC 5.1 or 5.2 that you should target, but only GCC 5.
    Then it is up to the user to use the latest available version of GCC 5, which is 5.5 at the time
    begin, just like the user would have selected 4.9.4 when 4.9 was the minimum GCC version.

    Christophe

    \
     
     \ /
      Last update: 2021-05-03 08:18    [W:8.917 / U:0.004 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site