lkml.org 
[lkml]   [2021]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/2] crypto: af_alg - use DIV_ROUND_UP helper macro for calculations
On Tue, May 25, 2021 at 10:37:44AM +0200, Christophe Leroy wrote:
> Wu Bo <wubo40@huawei.com> a écrit :
>
> > From: Wu Bo <wubo40@huawei.com>
> >
> > Replace open coded divisor calculations with the DIV_ROUND_UP kernel
> > macro for better readability.
> >
> > Signed-off-by: Wu Bo <wubo40@huawei.com>
> > ---
> > crypto/af_alg.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/crypto/af_alg.c b/crypto/af_alg.c
> > index 18cc82d..8bd288d 100644
> > --- a/crypto/af_alg.c
> > +++ b/crypto/af_alg.c
> > @@ -411,7 +411,7 @@ int af_alg_make_sg(struct af_alg_sgl *sgl, struct
> > iov_iter *iter, int len)
> > if (n < 0)
> > return n;
> >
> > - npages = (off + n + PAGE_SIZE - 1) >> PAGE_SHIFT;
> > + npages = DIV_ROUND_UP(off + n, PAGE_SIZE);
>
> You should use PFN_UP()

No. We are not using pfns here - we're converting a byte count to a
page count.

Besides, "PFN_UP" is a horrible, awful api. It does not decribe what
it does and anyone who is not a mm developer will look at it and ask
"what <the ....> does this do?" and have to go looking for it's
definition to determine what it does. Yes, that's exactyl what I've
just done, and I really wish I didn't because, well, it just
reinforces how much we suck at APIs...

OTOH, what DIV_ROUND_UP() does is obvious, widely understood, self
documenting and easy to determine if the usage is correct, which
indeed this is.

The lesson: do not use whacky obscure, out of context macros when a
simple, obvious, widely known macro will give the same result and
make the code easier to understand.

Cheers,

Dave.
--
Dave Chinner
david@fromorbit.com

\
 
 \ /
  Last update: 2021-05-26 10:32    [W:2.274 / U:0.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site