lkml.org 
[lkml]   [2021]   [May]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v8,1/4] X.509: Add CodeSigning extended key usage parsing
Hi Jarkko,

On Tue, May 25, 2021 at 12:33:34AM +0300, Jarkko Sakkinen wrote:
> On Mon, May 24, 2021 at 10:15:37AM +0800, Lee, Chun-Yi wrote:
> > This patch adds the logic for parsing the CodeSign extended key usage
> > extension in X.509. The parsing result will be set to the eku flag
> > which is carried by public key. It can be used in the PKCS#7
> > verification.
> >
> > Signed-off-by: "Lee, Chun-Yi" <jlee@suse.com>
> > ---
> > crypto/asymmetric_keys/x509_cert_parser.c | 25 +++++++++++++++++++++++++
> > include/crypto/public_key.h | 1 +
> > include/linux/oid_registry.h | 5 +++++
> > 3 files changed, 31 insertions(+)
> >
> > diff --git a/crypto/asymmetric_keys/x509_cert_parser.c b/crypto/asymmetric_keys/x509_cert_parser.c
> > index 6d003096b5bc..996db9419474 100644
> > --- a/crypto/asymmetric_keys/x509_cert_parser.c
> > +++ b/crypto/asymmetric_keys/x509_cert_parser.c
> > @@ -542,6 +542,8 @@ int x509_process_extension(void *context, size_t hdrlen,
> > struct x509_parse_context *ctx = context;
> > struct asymmetric_key_id *kid;
> > const unsigned char *v = value;
> > + int i = 0;
> > + enum OID oid;
> >
> > pr_debug("Extension: %u\n", ctx->last_oid);
> >
> > @@ -571,6 +573,29 @@ int x509_process_extension(void *context, size_t hdrlen,
> > return 0;
> > }
> >
> > + if (ctx->last_oid == OID_extKeyUsage) {
> > + if (vlen < 2 ||
> > + v[0] != ((ASN1_UNIV << 6) | ASN1_CONS_BIT | ASN1_SEQ) ||
> > + v[1] != vlen - 2)
> > + return -EBADMSG;
> > + i += 2;
> > +
> > + while (i < vlen) {
> > + /* A 10 bytes EKU OID Octet blob =
> > + * ASN1_OID + size byte + 8 bytes OID */
> > + if ((i + 10) > vlen || v[i] != ASN1_OID || v[i + 1] != 8)
> > + return -EBADMSG;
> > +
> > + oid = look_up_OID(v + i + 2, v[i + 1]);
> > + if (oid == OID_codeSigning) {
> > + ctx->cert->pub->eku |= EKU_codeSigning;
> > + }
> > + i += 10;
> > + }
> > + pr_debug("extKeyUsage: %d\n", ctx->cert->pub->eku);
> > + return 0;
> > + }
> > +
> > return 0;
> > }
> >
> > diff --git a/include/crypto/public_key.h b/include/crypto/public_key.h
> > index 47accec68cb0..1ccaebe2a28b 100644
> > --- a/include/crypto/public_key.h
> > +++ b/include/crypto/public_key.h
> > @@ -28,6 +28,7 @@ struct public_key {
> > bool key_is_private;
> > const char *id_type;
> > const char *pkey_algo;
> > + unsigned int eku : 9; /* Extended Key Usage (9-bit) */
>
> Why no just name it ext_key_usage? I get the use of "EKU" elsewhere
> but not in the variable name. Now you have to remember too much
> context when just looking at this (and it's even undocumented to
> add that).
>

Thanks for your suggestion. I will use a better name in next version.

Joey Lee

> > };
> >
> > extern void public_key_free(struct public_key *key);
> > diff --git a/include/linux/oid_registry.h b/include/linux/oid_registry.h
> > index 461b7aa587ba..8c8935f0eb73 100644
> > --- a/include/linux/oid_registry.h
> > +++ b/include/linux/oid_registry.h
> > @@ -125,9 +125,14 @@ enum OID {
> > OID_TPMImportableKey, /* 2.23.133.10.1.4 */
> > OID_TPMSealedData, /* 2.23.133.10.1.5 */
> >
> > + /* Extended key purpose OIDs [RFC 5280] */
> > + OID_codeSigning, /* 1.3.6.1.5.5.7.3.3 */
> > +
> > OID__NR
> > };
> >
> > +#define EKU_codeSigning (1 << 2)
> > +
> > extern enum OID look_up_OID(const void *data, size_t datasize);
> > extern int parse_OID(const void *data, size_t datasize, enum OID *oid);
> > extern int sprint_oid(const void *, size_t, char *, size_t);
> > --
> > 2.16.4
> >
> >005diaq6539262
>
>
> /Jarkko

\
 
 \ /
  Last update: 2021-05-25 12:37    [W:0.067 / U:0.412 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site