Messages in this thread Patch in this message |  | | Subject | Re: [PATCH v4,6/6] media: mtk-vcodec: Support MT8192 H264 4K encoding | From | Irui Wang <> | Date | Mon, 24 May 2021 10:39:18 +0800 |
| |
On Fri, 2021-05-21 at 16:06 +0800, Tzung-Bi Shih wrote: > On Fri, May 21, 2021 at 3:02 PM Irui Wang <irui.wang@mediatek.com> wrote: > > fsize->type = V4L2_FRMSIZE_TYPE_STEPWISE; > > - fsize->stepwise = mtk_venc_framesizes; > > + fsize->stepwise = > > + (ctx->dev->enc_capability & MTK_VENC_4K_CAPABILITY_ENABLE) ? > > + mtk_venc_4k_framesizes : mtk_venc_hd_framesizes; > > Use a normal if .. else .. is more readable. if (ctx->dev->enc_capability & MTK_VENC_4K_CAPABILITY_ENABLE) fsize->stepwise = mtk_venc_4k_framesizes; else fsize->stepwise = mtk_venc_hd_framesizes;
> > > @@ -1210,6 +1231,9 @@ int mtk_vcodec_enc_ctrls_setup(struct mtk_vcodec_ctx *ctx) > > { > > const struct v4l2_ctrl_ops *ops = &mtk_vcodec_enc_ctrl_ops; > > struct v4l2_ctrl_handler *handler = &ctx->ctrl_hdl; > > + const u8 h264_max_level = > > + (ctx->dev->enc_capability & MTK_VENC_4K_CAPABILITY_ENABLE) ? > > + V4L2_MPEG_VIDEO_H264_LEVEL_5_1 : V4L2_MPEG_VIDEO_H264_LEVEL_4_2; > Again, I would like it to be a normal if .. else .. u8 h264_max_level; if (ctx->dev->enc_capability & MTK_VENC_4K_CAPABILITY_ENABLE) h264_max_level = V4L2_MPEG_VIDEO_H264_LEVEL_5_1; else h264_max_level = V4L2_MPEG_VIDEO_H264_LEVEL_4_2;
Patch V5 will be sent with these if there is no more comments.
|  |