lkml.org 
[lkml]   [2021]   [May]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v2 04/22] arch/arm64/kvm: Use vma_lookup() instead of find_vma_intersection()
    Date
    vma_lookup() finds the vma of a specific address with a cleaner
    interface and is more readable.

    Signed-off-by: Liam R. Howlett <Liam.Howlett@Oracle.com>
    Reviewed-by: Laurent Dufour <ldufour@linux.ibm.com>
    Acked-by: David Hildenbrand <david@redhat.com>
    Acked-by: Davidlohr Bueso <dbueso@suse.de>
    ---
    arch/arm64/kvm/mmu.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/arch/arm64/kvm/mmu.c b/arch/arm64/kvm/mmu.c
    index c5d1f3c87dbd..8b112b594e09 100644
    --- a/arch/arm64/kvm/mmu.c
    +++ b/arch/arm64/kvm/mmu.c
    @@ -855,7 +855,7 @@ static int user_mem_abort(struct kvm_vcpu *vcpu, phys_addr_t fault_ipa,

    /* Let's check if we will get back a huge page backed by hugetlbfs */
    mmap_read_lock(current->mm);
    - vma = find_vma_intersection(current->mm, hva, hva + 1);
    + vma = vma_lookup(current->mm, hva);
    if (unlikely(!vma)) {
    kvm_err("Failed to find VMA for hva 0x%lx\n", hva);
    mmap_read_unlock(current->mm);
    --
    2.30.2
    \
     
     \ /
      Last update: 2021-05-21 19:48    [W:6.442 / U:0.004 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site