lkml.org 
[lkml]   [2021]   [May]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH][next] gpio: xilinx: Fix potential integer overflow on shift of a u32 int
On Thu, May 13, 2021 at 09:52:27AM +0100, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
>
> The left shift of the u32 integer v is evaluated using 32 bit
> arithmetic and then assigned to a u64 integer. There are cases
> where v will currently overflow on the shift. Avoid this by
> casting it to unsigned long (same type as map[]) before shifting
> it.
>
> Addresses-Coverity: ("Unintentional integer overflow")
> Fixes: 02b3f84d9080 ("gpio: xilinx: Switch to use bitmap APIs")
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
> drivers/gpio/gpio-xilinx.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpio/gpio-xilinx.c b/drivers/gpio/gpio-xilinx.c
> index 109b32104867..164a3a5a9393 100644
> --- a/drivers/gpio/gpio-xilinx.c
> +++ b/drivers/gpio/gpio-xilinx.c
> @@ -99,7 +99,7 @@ static inline void xgpio_set_value32(unsigned long *map, int bit, u32 v)
> const unsigned long offset = (bit % BITS_PER_LONG) & BIT(5);
>
> map[index] &= ~(0xFFFFFFFFul << offset);
> - map[index] |= v << offset;
> + map[index] |= (unsigned long)v << offset;

Doing a shift by BIT(5) is super weird. It looks like a double shift
bug and should probably trigger a static checker warning. It's like
when people do BIT(BIT(5)).

It would be more readable to write it as:

int shift = (bit % BITS_PER_LONG) ? 32 : 0;

regards,
dan carpenter

\
 
 \ /
  Last update: 2021-05-14 07:39    [W:0.105 / U:0.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site