lkml.org 
[lkml]   [2021]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH][next] usb: mtu3: Fix spelling mistake "disabed" -> "disabled"
From
Date
On Thu, 2021-03-11 at 09:25 +0000, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
>
> The variable u3_ports_disabed contains a spelling mistake,
> rename it to u3_ports_disabled.
>
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
> drivers/usb/mtu3/mtu3_host.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/usb/mtu3/mtu3_host.c b/drivers/usb/mtu3/mtu3_host.c
> index c871b94f3e6f..41a5675ac5ca 100644
> --- a/drivers/usb/mtu3/mtu3_host.c
> +++ b/drivers/usb/mtu3/mtu3_host.c
> @@ -109,7 +109,7 @@ int ssusb_host_enable(struct ssusb_mtk *ssusb)
> void __iomem *ibase = ssusb->ippc_base;
> int num_u3p = ssusb->u3_ports;
> int num_u2p = ssusb->u2_ports;
> - int u3_ports_disabed;
> + int u3_ports_disabled;
> u32 check_clk;
> u32 value;
> int i;
> @@ -118,10 +118,10 @@ int ssusb_host_enable(struct ssusb_mtk *ssusb)
> mtu3_clrbits(ibase, U3D_SSUSB_IP_PW_CTRL1, SSUSB_IP_HOST_PDN);
>
> /* power on and enable u3 ports except skipped ones */
> - u3_ports_disabed = 0;
> + u3_ports_disabled = 0;
> for (i = 0; i < num_u3p; i++) {
> if ((0x1 << i) & ssusb->u3p_dis_msk) {
> - u3_ports_disabed++;
> + u3_ports_disabled++;
> continue;
> }
>
> @@ -140,7 +140,7 @@ int ssusb_host_enable(struct ssusb_mtk *ssusb)
> }
>
> check_clk = SSUSB_XHCI_RST_B_STS;
> - if (num_u3p > u3_ports_disabed)
> + if (num_u3p > u3_ports_disabled)
> check_clk = SSUSB_U3_MAC_RST_B_STS;
Reviewed-by: Chunfeng Yun <chunfeng.yun@mediatek.com>

Thanks a lot


>
> return ssusb_check_clocks(ssusb, check_clk);

\
 
 \ /
  Last update: 2021-03-12 09:40    [W:0.066 / U:0.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site