lkml.org 
[lkml]   [2021]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectRe: [PATCH v2 6/7] KVM: x86: Introduce definitions to support static calls for kvm_pmu_ops
    On Mon, Nov 08, 2021, Like Xu wrote:
    > From: Like Xu <likexu@tencent.com>
    >
    > Use static calls to improve kvm_pmu_ops performance. Introduce the
    > definitions that will be used by a subsequent patch to actualize the
    > savings. Add a new kvm-x86-pmu-ops.h header that can be used for the
    > definition of static calls. This header is also intended to be
    > used to simplify the defition of amd_pmu_ops and intel_pmu_ops.
    >
    > Like what we did for kvm_x86_ops, 'pmu_ops' can be covered by
    > static calls in a simlilar manner for insignificant but not
    > negligible performance impact, especially on older models.
    >
    > Signed-off-by: Like Xu <likexu@tencent.com>
    > ---

    This absolutely shouldn't be separated from patch 7/7. By _defining_ the static
    calls but not providing the logic to actually _update_ the calls, it's entirely
    possible to add static_call() invocations that will compile cleanly without any
    chance of doing the right thing at runtime.

    diff --git a/arch/x86/kvm/pmu.h b/arch/x86/kvm/pmu.h
    index 0236c1a953d0..804f98b5552e 100644
    --- a/arch/x86/kvm/pmu.h
    +++ b/arch/x86/kvm/pmu.h
    @@ -99,7 +99,7 @@ static inline bool pmc_is_fixed(struct kvm_pmc *pmc)

    static inline bool pmc_is_enabled(struct kvm_pmc *pmc)
    {
    - return kvm_pmu_ops.pmc_is_enabled(pmc);
    + return static_call(kvm_x86_pmu_pmc_is_enabled)(pmc);
    }

    static inline bool kvm_valid_perf_global_ctrl(struct kvm_pmu *pmu,
    > @@ -0,0 +1,32 @@
    > +/* SPDX-License-Identifier: GPL-2.0 */
    > +#if !defined(KVM_X86_PMU_OP) || !defined(KVM_X86_PMU_OP_NULL)
    > +BUILD_BUG_ON(1)
    > +#endif
    > +
    > +/*
    > + * KVM_X86_PMU_OP() and KVM_X86_PMU_OP_NULL() are used to

    Please use all 80 chars.

    > + * help generate "static_call()"s. They are also intended for use when defining
    > + * the amd/intel KVM_X86_PMU_OPs. KVM_X86_PMU_OP() can be used

    AMD/Intel since this is referring to the vendor and not to function names (like
    the below reference).

    > + * for those functions that follow the [amd|intel]_func_name convention.
    > + * KVM_X86_PMU_OP_NULL() can leave a NULL definition for the

    As below, please drop the _NULL() variant.

    > + * case where there is no definition or a function name that
    > + * doesn't match the typical naming convention is supplied.
    > + */

    ...

    > diff --git a/arch/x86/kvm/pmu.c b/arch/x86/kvm/pmu.c
    > index 353989bf0102..bfdd9f2bc0fa 100644
    > --- a/arch/x86/kvm/pmu.c
    > +++ b/arch/x86/kvm/pmu.c
    > @@ -50,6 +50,12 @@
    > struct kvm_pmu_ops kvm_pmu_ops __read_mostly;
    > EXPORT_SYMBOL_GPL(kvm_pmu_ops);
    >
    > +#define KVM_X86_PMU_OP(func) \
    > + DEFINE_STATIC_CALL_NULL(kvm_x86_pmu_##func, \
    > + *(((struct kvm_pmu_ops *)0)->func))
    > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP
    > +#include <asm/kvm-x86-pmu-ops.h>
    > +
    > static void kvm_pmi_trigger_fn(struct irq_work *irq_work)
    > {
    > struct kvm_pmu *pmu = container_of(irq_work, struct kvm_pmu, irq_work);
    > diff --git a/arch/x86/kvm/pmu.h b/arch/x86/kvm/pmu.h
    > index b2fe135d395a..40e0b523637b 100644
    > --- a/arch/x86/kvm/pmu.h
    > +++ b/arch/x86/kvm/pmu.h
    > @@ -45,6 +45,11 @@ struct kvm_pmu_ops {
    > void (*cleanup)(struct kvm_vcpu *vcpu);
    > };
    >
    > +#define KVM_X86_PMU_OP(func) \
    > + DECLARE_STATIC_CALL(kvm_x86_pmu_##func, *(((struct kvm_pmu_ops *)0)->func))
    > +#define KVM_X86_PMU_OP_NULL KVM_X86_PMU_OP

    I don't want to proliferate the pointless and bitrot-prone KVM_X86_OP_NULL macro,
    just omit this. I'll send a patch to drop KVM_X86_OP_NULL.

    > +#include <asm/kvm-x86-pmu-ops.h>
    > +
    > static inline u64 pmc_bitmask(struct kvm_pmc *pmc)
    > {
    > struct kvm_pmu *pmu = pmc_to_pmu(pmc);
    > --
    > 2.33.0
    >

    \
     
     \ /
      Last update: 2021-12-08 19:36    [W:4.514 / U:0.084 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site