lkml.org 
[lkml]   [2021]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] sysctl: Add a group of macro functions to initcall the sysctl table of each feature
On Tue, 7 Dec 2021 09:13:20 +0800 Xiaoming Ni <nixiaoming@huawei.com> wrote:

> To avoid duplicated code, add a set of macro functions to initialize the
> sysctl table for each feature.
>
> The system initialization process is as follows:
>
> start_kernel () {
> ...
> /* init proc and sysctl base,
> * proc_root_init()-->proc_sys_init()-->sysctl_init_bases()
> */
> proc_root_init(); /* init proc and sysctl base */
> ...
> arch_call_rest_init();
> }
>
> arch_call_rest_init()-->rest_init()-->kernel_init()
> kernel_init() {
> ...
> kernel_init_freeable(); /* do all initcalls */
> ...
> do_sysctl_args(); /* Process the sysctl parameter: sysctl.*= */
> }
>
> kernel_init_freeable()--->do_basic_setup()-->do_initcalls()
> do_initcalls() {
> for (level = 0; level < ARRAY_SIZE(initcall_levels) - 1; level++) {
> do_initcall_level
> }
>
> The sysctl interface of each subfeature should be registered after
> sysctl_init_bases() and before do_sysctl_args(). It seems that the sysctl
> interface does not depend on initcall_levels. To prevent the sysctl
> interface from being initialized before the feature itself. The
> lowest-level late_initcall() is used as the common sysctl interface
> registration level.

I'm not normally a fan of wrapping commonly-used code sequences into
magical macros, but this one does seem to make sense.

I wonder if it is possible to cook up a checkpatch rule to tell people
to henceforth use the magic macros rather than to open-code things in
the old way. Sounds hard.

> --- a/fs/coredump.c
> +++ b/fs/coredump.c
> @@ -943,12 +943,7 @@ static struct ctl_table coredump_sysctls[] = {
> { }
> };
>
> -static int __init init_fs_coredump_sysctls(void)
> -{
> - register_sysctl_init("kernel", coredump_sysctls);
> - return 0;
> -}
> -fs_initcall(init_fs_coredump_sysctls);
> +kernel_sysctl_initcall(coredump_sysctls);

But this and several like it are functional changes.

> #endif /* CONFIG_SYSCTL */
>
> ...
>
> --- a/fs/inode.c
> +++ b/fs/inode.c
> @@ -132,12 +132,7 @@ static struct ctl_table inodes_sysctls[] = {
> { }
> };
>
> -static int __init init_fs_inode_sysctls(void)
> -{
> - register_sysctl_init("fs", inodes_sysctls);
> - return 0;
> -}
> -early_initcall(init_fs_inode_sysctls);
> +fs_sysctl_initcall(inodes_sysctls);
> #endif

Here's another, of many.

Someone made the decision to use early_initcall() here (why?) and this
patch switches it to late_initcall()! Worrisome. Each such stealth
conversion should be explained and justified, shouldn't it?


\
 
 \ /
  Last update: 2021-12-07 02:40    [W:0.627 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site