lkml.org 
[lkml]   [2021]   [Dec]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH mm v5 13/39] kasan, page_alloc: move kernel_init_free_pages in post_alloc_hook
    Date
    From: Andrey Konovalov <andreyknvl@google.com>

    Pull the kernel_init_free_pages() call in post_alloc_hook() out of the
    big if clause for better code readability. This also allows for more
    simplifications in the following patch.

    This patch does no functional changes.

    Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
    Reviewed-by: Alexander Potapenko <glider@google.com>
    ---
    mm/page_alloc.c | 12 ++++++++----
    1 file changed, 8 insertions(+), 4 deletions(-)

    diff --git a/mm/page_alloc.c b/mm/page_alloc.c
    index d96a43db90c8..ddf677c23298 100644
    --- a/mm/page_alloc.c
    +++ b/mm/page_alloc.c
    @@ -2435,14 +2435,18 @@ inline void post_alloc_hook(struct page *page, unsigned int order,
    init = false;
    }
    if (kasan_has_integrated_init()) {
    - if (!init_tags)
    + if (!init_tags) {
    kasan_unpoison_pages(page, order, init);
    +
    + /* Note that memory is already initialized by KASAN. */
    + init = false;
    + }
    } else {
    kasan_unpoison_pages(page, order, init);
    -
    - if (init)
    - kernel_init_free_pages(page, 1 << order);
    }
    + /* If memory is still not initialized, do it now. */
    + if (init)
    + kernel_init_free_pages(page, 1 << order);
    /* Propagate __GFP_SKIP_KASAN_POISON to page flags. */
    if (kasan_hw_tags_enabled() && (gfp_flags & __GFP_SKIP_KASAN_POISON))
    SetPageSkipKASanPoison(page);
    --
    2.25.1
    \
     
     \ /
      Last update: 2021-12-30 20:14    [W:2.807 / U:0.448 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site