Messages in this thread |  | | Date | Fri, 3 Dec 2021 14:45:37 +0800 | From | Peter Xu <> | Subject | Re: [PATCH v6 01/23] mm: Introduce PTE_MARKER swap entry |
| |
On Fri, Dec 03, 2021 at 04:35:38PM +1100, Alistair Popple wrote: > > > > +static inline pte_marker pte_marker_get(swp_entry_t entry) > > > > +{ > > > > + return swp_offset(entry) & PTE_MARKER_MASK; > > > > > > I'm not sure the PTE_MARKER_MASK adds much, especially as we only have one > > > user. I don't see a problem with open-coding these kind of checks (ie. > > > > It's more or less a safety belt to make sure anything pte_marker_get() returned > > will be pte_marker defined bits only. > > > > > swp_offset(entry) & PTE_MARKER_UFFD_WP) as you kind of end up doing that anyway. > > > Alternatively if you want helper functions I think it would be better to define > > > them for each marker. Eg: is_pte_marker_uffd_wp(). > > > > Yes we can have something like is_pte_marker_uffd_wp(), I didn't do that > > explicitly because I want us to be clear that pte_marker is a bitmask, so > > calling "is_*" will be slightly opaque - strictly speaking it should be > > "pte_marker_has_uffd_wp_bit()" if there will be more bits defined, but then the > > name of the helper will look a bit odd too. Hence I just keep the only > > interface to fetch the whole marker and use "&" in the call sites to check. > > Why does a caller need to care if it's a bitmask or not though? Isn't that an > implementation detail that could be left to the "is_*" functions? I must admit > I'm still working through the rest of this series though - is it because you > end up storing some kind of value in the upper bits of the PTE marker?
Nop. I'm just afraid the caller could overlook the fact that it's a bitmask, then there can be code like:
if (is_pte_marker_uffd_wp(*ptep) && drop_uffd_wp) pte_clear(ptep)
While we should only do:
if (is_pte_marker_uffd_wp(*ptep) && drop_uffd_wp) // remove uffd-wp bit in the pte_marker, keep the reset bitmask
I could be worrying too much, there's no real user of it. If you prefer the helper a lot I can add it in the new version. Thanks,
-- Peter Xu
|  |