lkml.org 
[lkml]   [2021]   [Dec]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 00/23] PCI: Name structs, functions consistently
On Wed, Dec 22, 2021 at 07:10:31PM -0600, Bjorn Helgaas wrote:
> From: Bjorn Helgaas <bhelgaas@google.com>
>
> This is a v2 of Fan's patches, previously posted at:
>
> https://lore.kernel.org/r/cover.1637678103.git.ffclaire1224@gmail.com
> https://lore.kernel.org/r/cover.1638021831.git.ffclaire1224@gmail.com
>
> I added a few more patches along the same lines and added driver
> maintainers to the cc lists.
>
> There should be no functional changes here at all; this is strictly to make
> the drivers more consistent so it's easier to see defects and opportunities
> for consolidation.
>
> Lorenzo, if this seems OK, I propose that I merge it after all of your
> branches so it doesn't get in the way of what you have pending.

That works for me, thank you very much for putting it together.

Lorenzo

>
> This series applies on v5.16-rc1.
>
> Bjorn Helgaas (10):
> PCI: j721e: Drop pointless of_device_get_match_data() cast
> PCI: j721e: Drop redundant struct device *
> PCI: iproc: Rename iproc_pcie_bcma_ to iproc_bcma_pcie_
> PCI: iproc: Rename iproc_pcie_pltfm_ to iproc_pltfm_pcie_
> PCI: ls-gen4: Rename ls_pcie_g4 to ls_g4_pcie
> PCI: microchip: Rename mc_port to mc_pcie
> PCI: mt7621: Make pci_ops static
> PCI: mt7621: Rename mt7621_pci_ to mt7621_pcie_
> PCI: rcar-gen2: Rename rcar_pci_priv to rcar_pci
> PCI: xilinx-cpm: Rename xilinx_cpm_pcie_port to xilinx_cpm_pcie
>
> Fan Fei (13):
> PCI: altera: Prefer of_device_get_match_data()
> PCI: artpec6: Prefer of_device_get_match_data()
> PCI: cadence: Prefer of_device_get_match_data()
> PCI: designware-plat: Prefer of_device_get_match_data()
> PCI: dra7xx: Prefer of_device_get_match_data()
> PCI: keystone: Prefer of_device_get_match_data()
> PCI: kirin: Prefer of_device_get_match_data()
> PCI: intel-gw: Rename intel_pcie_port to intel_pcie
> PCI: mediatek-gen3: Rename mtk_pcie_port to mtk_gen3_pcie
> PCI: tegra194: Rename tegra_pcie_dw to tegra194_pcie
> PCI: uniphier: Rename uniphier_pcie_priv to uniphier_pcie
> PCI: xgene: Rename xgene_pcie_port to xgene_pcie
> PCI: xilinx: Rename xilinx_pcie_port to xilinx_pcie
>
> drivers/pci/controller/cadence/pci-j721e.c | 18 +-
> .../controller/cadence/pcie-cadence-plat.c | 6 +-
> drivers/pci/controller/dwc/pci-dra7xx.c | 6 +-
> drivers/pci/controller/dwc/pci-keystone.c | 4 +-
> drivers/pci/controller/dwc/pcie-artpec6.c | 6 +-
> .../pci/controller/dwc/pcie-designware-plat.c | 6 +-
> drivers/pci/controller/dwc/pcie-intel-gw.c | 204 +++++-----
> drivers/pci/controller/dwc/pcie-kirin.c | 6 +-
> drivers/pci/controller/dwc/pcie-tegra194.c | 222 +++++------
> drivers/pci/controller/dwc/pcie-uniphier.c | 147 +++----
> .../mobiveil/pcie-layerscape-gen4.c | 84 ++--
> drivers/pci/controller/pci-rcar-gen2.c | 14 +-
> drivers/pci/controller/pci-xgene.c | 46 +--
> drivers/pci/controller/pcie-altera.c | 8 +-
> drivers/pci/controller/pcie-iproc-bcma.c | 22 +-
> drivers/pci/controller/pcie-iproc-platform.c | 16 +-
> drivers/pci/controller/pcie-mediatek-gen3.c | 372 +++++++++---------
> drivers/pci/controller/pcie-microchip-host.c | 42 +-
> drivers/pci/controller/pcie-mt7621.c | 36 +-
> drivers/pci/controller/pcie-xilinx-cpm.c | 44 +--
> drivers/pci/controller/pcie-xilinx.c | 158 ++++----
> 21 files changed, 727 insertions(+), 740 deletions(-)
>
> --
> 2.25.1
>

\
 
 \ /
  Last update: 2021-12-26 13:05    [W:0.188 / U:0.116 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site