lkml.org 
[lkml]   [2021]   [Dec]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH v18 07/17] x86/setup: Eliminate a magic number in reserve_crashkernel()
Date
From: Chen Zhou <chenzhou10@huawei.com>

Replace '(1ULL << 32)' with CRASH_ADDR_LOW_MAX to improve readability,
they are equal.

Signed-off-by: Chen Zhou <chenzhou10@huawei.com>
Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com>
---
arch/x86/kernel/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 52aa925877ca787..abff57ffbe92884 100644
--- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c
@@ -523,7 +523,7 @@ static void __init reserve_crashkernel(void)
}

#ifdef CONFIG_X86_64
- if (crash_base >= (1ULL << 32)) {
+ if (crash_base >= CRASH_ADDR_LOW_MAX) {
/*
* Ensure that at least 256M extra low memory is allocated for
* DMA buffers and swiotlb, if low memory size is not specified.
--
2.25.1
\
 
 \ /
  Last update: 2021-12-22 14:13    [W:0.601 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site