lkml.org 
[lkml]   [2021]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v8 0/6] Add Unisoc's drm kms module
Dear Maarten,
I see it from the cgit.freedesktop.org, our sprd drivers seems has
been merged into drm-misc.

Now, what shall we do next?

BR,
Best wishes

Kevin Tang <kevin3.tang@gmail.com> 于2021年12月7日周二 22:27写道:

>
> ChangeList:
> RFC v1:
> 1. only upstream modeset and atomic at first commit.
> 2. remove some unused code;
> 3. use alpha and blend_mode properties;
> 3. add yaml support;
> 4. remove auto-adaptive panel driver;
> 5. bugfix
>
> RFC v2:
> 1. add sprd crtc and plane module for KMS, preparing for multi crtc&encoder
> 2. remove gem drivers, use generic CMA handlers
> 3. remove redundant "module_init", all the sub modules loading by KMS
>
> RFC v3:
> 1. multi crtc&encoder design have problem, so rollback to v1
>
> RFC v4:
> 1. update to gcc-linaro-7.5.0
> 2. update to Linux 5.6-rc3
> 3. remove pm_runtime support
> 4. add COMPILE_TEST, remove unused kconfig
> 5. "drm_dev_put" on drm_unbind
> 6. fix some naming convention issue
> 7. remove semaphore lock for crtc flip
> 8. remove static variables
>
> RFC v5:
> 1. optimize encoder and connector code implementation
> 2. use "platform_get_irq" and "platform_get_resource"
> 3. drop useless function return type, drop unless debug log
> 4. custom properties should be separate, so drop it
> 5. use DRM_XXX replase pr_xxx
> 6. drop dsi&dphy hal callback ops
> 7. drop unless callback ops checking
> 8. add comments for sprd dpu structure
>
> RFC v6:
> 1. Access registers via readl/writel
> 2. Checking for unsupported KMS properties (format, rotation, blend_mode, etc) on plane_check ops
> 3. Remove always true checks for dpu core ops
>
> RFC v7:
> 1. Fix DTC unit name warnings
> 2. Fix the problem of maintainers
> 3. Call drmm_mode_config_init to mode config init
> 4. Embed drm_device in sprd_drm and use devm_drm_dev_alloc
> 5. Replace DRM_XXX with drm_xxx on KMS module, but not suitable for other subsystems
> 6. Remove plane_update stuff, dpu handles all the HW update in crtc->atomic_flush
> 7. Dsi&Dphy Code structure adjustment, all move to "sprd/"
>
> v0:
> 1. Remove dpu_core_ops stuff layer for sprd drtc driver, but dpu_layer need to keeping.
> Because all the HW update in crtc->atomic_flush, we need temporary storage all layers for
> the dpu pageflip of atomic_flush.
> 2. Add ports subnode with port@X.
>
> v1:
> 1. Remove dphy and dsi graph binding, merge the dphy driver into the dsi.
> 2. Add commit messages for Unisoc's virtual nodes.
>
> v2:
> 1. Use drm_xxx to replace all DRM_XXX.
> 2. Use kzalloc to replace devm_kzalloc for sprd_dsi/sprd_dpu structure init.
> 3. Remove dpu_core_ops midlayer.
>
> v3:
> 1. Remove dpu_layer midlayer and commit layers by aotmic_update
>
> v4:
> 1. Move the devm_drm_dev_alloc to master_ops->bind function.
> 2. The managed drmm_mode_config_init() it is no longer necessary for drivers to explicitly call drm_mode_config_cleanup, so delete it.
> 3. Use drmm_helpers to allocate crtc ,planes and encoder.
> 4. Move allocate crtc ,planes, encoder to bind funtion.
> 5. Move rotation enum definitions to crtc layer reg bitfields.
>
> v5:
> 1. Remove subdir-ccflgas-y for Makefile.
> 2. Keep the selects sorted by alphabet for Kconfig.
> 3. Fix the checkpatch warnings.
> 4. Use mode_set_nofb instead of mode_valid callback.
> 5. Follow the OF-Graph bindings, use of_graph_get_port_by_id instead of of_parse_phandle.
> 6. Use zpos to represent the layer position.
> 7. Rebase to last drm misc branch.
> 8. Remove panel_in port for dsi node.
> 9. Drop the dsi ip file prefix.
> 10. Add Signed-off-by for dsi&dphy patch.
> 11. Use the mode_flags of mipi_dsi_device to setup crtc DPI and EDPI mode.
>
> v6:
> 1. Disable and clear interrupts before register dpu IRQ
> 2. Init dpi config used by crtc_state->adjusted_mode on mode_set_nofb
> 3. Remove enable_irq and disable_irq function call.
> 4. Remove drm_format_info function call.
> 5. Redesign the way to access the dsi register.
> 6. Reduce the dsi_context member variables.
>
> v7:
> 1. Fix codeing style issue by checkpatch.
> 2. Drop the pll registers structure define.
> 3. Use bridge API instead of drm panel API.
> 4. Register mipi_dsi_host on probe phase;
> 5. Remove iommu error interrupt handling function.
> 6. Remove some unused function.
>
> v8:
> 1. Fix missing signed-off-by.
> 2. Move component_add to dsi_host.attach callback.
>
> Kevin Tang (6):
> dt-bindings: display: add Unisoc's drm master bindings
> drm/sprd: add Unisoc's drm kms master
> dt-bindings: display: add Unisoc's dpu bindings
> drm/sprd: add Unisoc's drm display controller driver
> dt-bindings: display: add Unisoc's mipi dsi controller bindings
> drm/sprd: add Unisoc's drm mipi dsi&dphy driver
>
> .../display/sprd/sprd,display-subsystem.yaml | 64 +
> .../display/sprd/sprd,sharkl3-dpu.yaml | 77 ++
> .../display/sprd/sprd,sharkl3-dsi-host.yaml | 88 ++
> drivers/gpu/drm/Kconfig | 2 +
> drivers/gpu/drm/Makefile | 1 +
> drivers/gpu/drm/sprd/Kconfig | 13 +
> drivers/gpu/drm/sprd/Makefile | 8 +
> drivers/gpu/drm/sprd/megacores_pll.c | 305 +++++
> drivers/gpu/drm/sprd/sprd_dpu.c | 880 ++++++++++++++
> drivers/gpu/drm/sprd/sprd_dpu.h | 109 ++
> drivers/gpu/drm/sprd/sprd_drm.c | 205 ++++
> drivers/gpu/drm/sprd/sprd_drm.h | 19 +
> drivers/gpu/drm/sprd/sprd_dsi.c | 1073 +++++++++++++++++
> drivers/gpu/drm/sprd/sprd_dsi.h | 126 ++
> 14 files changed, 2970 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,display-subsystem.yaml
> create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dpu.yaml
> create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dsi-host.yaml
> create mode 100644 drivers/gpu/drm/sprd/Kconfig
> create mode 100644 drivers/gpu/drm/sprd/Makefile
> create mode 100644 drivers/gpu/drm/sprd/megacores_pll.c
> create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.c
> create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.h
> create mode 100644 drivers/gpu/drm/sprd/sprd_drm.c
> create mode 100644 drivers/gpu/drm/sprd/sprd_drm.h
> create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.c
> create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.h
>
> --
> 2.29.0
>

\
 
 \ /
  Last update: 2021-12-20 14:58    [W:0.088 / U:0.580 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site