lkml.org 
[lkml]   [2021]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3] LICENSES/LGPL-2.1: Add LGPL-2.1-or-later as valid identifiers
On 16 12月 21 13:17:35, Mauro Carvalho Chehab wrote:
> Some files have been flagged with the new LGPL-2.1-or-later
> identifier which replace the original LGPL-2.1+ in the SPDX license
> identifier specification, but the identifiers are not mentioned as
> valid in the LGPL-2.1 license file.
>
> Add it, together with the LGPL-2.1-only at the the license file.
>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
> ---
> LICENSES/preferred/LGPL-2.1 | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/LICENSES/preferred/LGPL-2.1 b/LICENSES/preferred/LGPL-2.1
> index 27bb4342a3e8..b73f9b6230f5 100644
> --- a/LICENSES/preferred/LGPL-2.1
> +++ b/LICENSES/preferred/LGPL-2.1
> @@ -1,5 +1,7 @@
> Valid-License-Identifier: LGPL-2.1
> +Valid-License-Identifier: LGPL-2.1-only
> Valid-License-Identifier: LGPL-2.1+
> +Valid-License-Identifier: LGPL-2.1-or-later
> SPDX-URL: https://spdx.org/licenses/LGPL-2.1.html
The URL is deprecated, do we need to update it together.
The same, GPL-2.0, LGPL-2.0
> Usage-Guide:
> To use this license in source code, put one of the following SPDX
> --
> 2.33.1
>

\
 
 \ /
  Last update: 2021-12-16 13:31    [W:5.370 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site