lkml.org 
[lkml]   [2021]   [Dec]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[ANNOUNCE] rt-tests-2.3
Date
I'm pleased to announce v2.3 of rt-tests

A few things included in this release:

- fixes in cyclicdeadline and deadline_test to prevent double mounting
of cgroups
- significant clean-ups and fixes to hwlatdetect
- aarch64 support for oslat
- The addition of the --default-system option in cyclictest
This runs cyclictest without attempting any tuning. Power management
is not suppressed so cyclictest measures the system as it is configured.
This may result in worse realtime behaviour, but is sometimes what you
are trying to measure.

Thank you to everyone who contributed.

Bug reports, testing, and patches are always appreciated.

You can get this version via git or tarballs as explained below.

Enjoy!

Clone
git://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git
https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git
https://kernel.googlesource.com/pub/scm/utils/rt-tests/rt-tests.git

Branch: main

Tag: v2.3

Tarballs are available here:
https://kernel.org/pub/linux/utils/rt-tests

Older version tarballs are available here:
https://kernel.org/pub/linux/utils/rt-tests/older


John Kacur (23):
rt-tests: pi_stress: Fix "id" in help
rt-tests: Add *.dat to .gitignore
rt-tests: Update the help and man page for --latency
rt-tests: cyclictest: Add --default-system option
rt-tests: cyclictest: Remove unused 'C' and 'E' options
rt-tests:hwlatdetect: Remove useless object in class declaration
rt-tests:hwlatdetect.py: Remove multiple statements on one line
rt-tests:hwlatdetect.py: Remove unnecessary 'not'
rt-tests: deadline_tests: Null check to prevent floating point
exception
rt-tests: cyclictest: Check user supplies an value to histogram
rt-tests: get_cyclictest_snapshot: print_warning should be a
classmethod
rt-tests: hwlatdetect: Remove unnessary parens after return
rt-tests: hwlatdetect: Use "with" for opening files
rt-tests: hwlatdetect: Use python3 style super()
rt-tests: hwlatdetect: Keep consistent name from abstract method
rt-tests: hwlatdetect: Remove class Hwlat
rt-tests: hwlatdetect: Use abstractmethod decorator
rt-tests: hwlatdetect: Remove unused class Kmod
rt-tests: hwlatdetect: Don't use built-in name str as a variable
rt-tests: deadline_test: Fix double mount of cgroups
rt-tests: cyclicdeadline: Fix double mount of cgroups
rt-tests: deadline_test: Fix typo "highes"
rt-tests: Change to version 2.3

Leah Leshchinsky (1):
rt-tests: Add missing option F to optstring

Nicolas Saenz Julienne (4):
oslat: Rename cpu_mhz/cpu_hz to counter_mhz/counter_hz
oslat: Add aarch64 support
oslat: Allow for arch specific counter frequency measurements
oslat: Avoid out-of-order memory accesses to precede counter read

Oscar Shiang (1):
rt-tests: cyclictest.8: Remove reference to -n in --system in manpage

Punit Agrawal (4):
rt-tests: hwlatdetect: Gracefully handle lack of /dev/cpu_dma_latency
rt-tests: cyclictest: Drop unused defines
rt-tests: cyclictest: Simplify duplicate initialization of "stop"
rt-tests: cyclictest: Drop unnecessary variable "bufsize"

.gitignore | 1 +
Makefile | 2 +-
src/cyclictest/cyclictest.8 | 17 +-
src/cyclictest/cyclictest.c | 40 ++-
src/cyclictest/get_cyclictest_snapshot.py | 7 +-
src/hwlatdetect/hwlatdetect.py | 388 ++++++++--------------
src/oslat/oslat.c | 52 ++-
src/pi_tests/pi_stress.c | 2 +-
src/sched_deadline/cyclicdeadline.c | 39 ++-
src/sched_deadline/deadline_test.c | 47 ++-
10 files changed, 288 insertions(+), 307 deletions(-)

--
2.31.1

\
 
 \ /
  Last update: 2021-12-10 19:47    [W:0.165 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site