lkml.org 
[lkml]   [2021]   [Nov]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] media: use swap() to make code cleaner
On Wed, Nov 3, 2021 at 10:34 AM <davidcomponentone@gmail.com> wrote:
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.

Same comments as per all your valuable contributions: just think more
about the code that you are dealing with!

> if (dev->fmt->uvswap) {
> - tmp = base2;
> - base2 = base3;
> - base3 = tmp;
> + swap(base2, base3);
> }

Have you run checkpatch? What did it say?

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2021-11-04 11:44    [W:2.225 / U:0.444 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site