lkml.org 
[lkml]   [2021]   [Nov]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] RDMA/mlx4: Use bitmap_alloc() when applicable
From
Date
On Thu, 2021-11-25 at 20:42 +0100, Christophe JAILLET wrote:
> Use 'bitmap_alloc()' to simplify code, improve the semantic and avoid some
> open-coded arithmetic in allocator arguments.
>
> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> consistency.

Thanks.

> diff --git a/drivers/infiniband/hw/mlx4/main.c b/drivers/infiniband/hw/mlx4/main.c
[]
> @@ -2784,10 +2784,8 @@ static void *mlx4_ib_add(struct mlx4_dev *dev)
> if (err)
> goto err_counter;
>
> - ibdev->ib_uc_qpns_bitmap =
> - kmalloc_array(BITS_TO_LONGS(ibdev->steer_qpn_count),
> - sizeof(long),
> - GFP_KERNEL);
> + ibdev->ib_uc_qpns_bitmap = bitmap_alloc(ibdev->steer_qpn_count,
> + GFP_KERNEL);

I wonder if it'd be simpler/smaller to change this to bitmap_zalloc and
remove the bitmap_zero in the if below.


\
 
 \ /
  Last update: 2021-11-25 21:01    [W:0.085 / U:0.336 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site