lkml.org 
[lkml]   [2021]   [Nov]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/2] sched/pelt: Change the type of parameter running to bool
From
Date
On 2021/11/25 17:55, Peter Zijlstra wrote:
> On Thu, Nov 25, 2021 at 11:00:19AM +0800, Tang Yizhou wrote:
>> Parameter 'running' in function ___update_load_sum() and
>> accumulate_sum() describes whether an se is running or not, so change
>> the type of it to bool to make the code more readable.
>>
>> Signed-off-by: Tang Yizhou <tangyizhou@huawei.com>
>> ---
>> kernel/sched/pelt.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/kernel/sched/pelt.c b/kernel/sched/pelt.c
>> index 3584df2a0b8e..2010b3bd6e49 100644
>> --- a/kernel/sched/pelt.c
>> +++ b/kernel/sched/pelt.c
>> @@ -104,7 +104,7 @@ static u32 __accumulate_pelt_segments(u64 periods, u32 d1, u32 d3)
>> */
>> static __always_inline u32
>> accumulate_sum(u64 delta, struct sched_avg *sa,
>> - unsigned long load, unsigned long runnable, int running)
>> + unsigned long load, unsigned long runnable, bool running)
>> {
>> u32 contrib = (u32)delta; /* p == 0 -> delta < 1024 */
>> u64 periods;
>> @@ -182,7 +182,7 @@ accumulate_sum(u64 delta, struct sched_avg *sa,
>> */
>> static __always_inline int
>> ___update_load_sum(u64 now, struct sched_avg *sa,
>> - unsigned long load, unsigned long runnable, int running)
>> + unsigned long load, unsigned long runnable, bool running)
>> {
>> u64 delta;
>
> And this function has:
>
> runnable = running = 0;
>
> and then people complain about assigning 0 to _Bool, and then we get
> idiocy like:
>
> runnable = running = false;
>
> Please...
> .
>

I see, assigning 0 to _Bool is inappropriate.
Thanks for your review.

\
 
 \ /
  Last update: 2021-11-25 14:02    [W:0.267 / U:0.060 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site