lkml.org 
[lkml]   [2021]   [Nov]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[GIT PULL] Folio fixes for 5.16
Hi Linus,

In the course of preparing the folio changes for iomap for next merge
window, we discovered some problems that would be nice to address now:

- Renaming multi-page folios to large folios.
mapping_multi_page_folio_support() is just a little too long, so
we settled on mapping_large_folio_support(). That meant renaming,
eg folio_test_multi() to folio_test_large().
- I hadn't included folio wrappers for zero_user_segments(), etc.
Also, multi-page^W^W large folio support is now independent of
CONFIG_TRANSPARENT_HUGEPAGE, so machines with HIGHMEM always need to
fall back to the out-of-line zero_user_segments().
- The build bots finally got round to telling me that I missed a
couple of architectures when adding flush_dcache_folio(). Christoph
suggested that we just add linux/cacheflush.h and not rely on
asm-generic/cacheflush.h.

These changes have been in linux-next for the last week with no new
squawks.

The following changes since commit 8ab774587903771821b59471cc723bba6d893942:

Merge tag 'trace-v5.16-5' of git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/linux-trace (2021-11-14 19:07:19 -0800)

are available in the Git repository at:

git://git.infradead.org/users/willy/pagecache.git tags/folio-5.16b

for you to fetch changes up to c035713998700e8843c7d087f55bce3c54c0e3ec:

mm: Add functions to zero portions of a folio (2021-11-18 15:05:56 -0500)

----------------------------------------------------------------
Fixes for 5.16 folios:

- Fix compilation warnings on csky and sparc
- Rename multipage folios to large folios
- Rename AS_THP_SUPPORT and FS_THP_SUPPORT
- Add functions to zero portions of a folio

----------------------------------------------------------------
Matthew Wilcox (Oracle) (6):
Add linux/cacheflush.h
mm: Rename folio_test_multi to folio_test_large
mm: Remove folio_test_single
fs: Remove FS_THP_SUPPORT
fs: Rename AS_THP_SUPPORT and mapping_thp_support
mm: Add functions to zero portions of a folio

arch/arc/include/asm/cacheflush.h | 1 -
arch/arm/include/asm/cacheflush.h | 1 -
arch/m68k/include/asm/cacheflush_mm.h | 1 -
arch/mips/include/asm/cacheflush.h | 2 --
arch/nds32/include/asm/cacheflush.h | 1 -
arch/nios2/include/asm/cacheflush.h | 1 -
arch/parisc/include/asm/cacheflush.h | 1 -
arch/sh/include/asm/cacheflush.h | 1 -
arch/xtensa/include/asm/cacheflush.h | 3 ---
fs/inode.c | 2 --
include/asm-generic/cacheflush.h | 6 -----
include/linux/cacheflush.h | 18 ++++++++++++++
include/linux/fs.h | 1 -
include/linux/highmem.h | 47 +++++++++++++++++++++++++++++++----
include/linux/page-flags.h | 14 +++++------
include/linux/pagemap.h | 26 +++++++++++++++----
mm/highmem.c | 2 --
mm/memcontrol.c | 2 +-
mm/shmem.c | 3 ++-
mm/util.c | 2 +-
20 files changed, 92 insertions(+), 43 deletions(-)
create mode 100644 include/linux/cacheflush.h


\
 
 \ /
  Last update: 2021-11-24 21:21    [W:0.050 / U:1.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site