lkml.org 
[lkml]   [2021]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 5.14 328/849] selftests/core: fix conflicting types compile error for close_range()
    Date
    From: Shuah Khan <skhan@linuxfoundation.org>

    [ Upstream commit f35dcaa0a8a29188ed61083d153df1454cf89d08 ]

    close_range() test type conflicts with close_range() library call in
    x86_64-linux-gnu/bits/unistd_ext.h. Fix it by changing the name to
    core_close_range().

    gcc -g -I../../../../usr/include/ close_range_test.c -o ../tools/testing/selftests/core/close_range_test
    In file included from close_range_test.c:16:
    close_range_test.c:57:6: error: conflicting types for ‘close_range’; have ‘void(struct __test_metadata *)’
    57 | TEST(close_range)
    | ^~~~~~~~~~~
    ../kselftest_harness.h:181:21: note: in definition of macro ‘__TEST_IMPL’
    181 | static void test_name(struct __test_metadata *_metadata); \
    | ^~~~~~~~~
    close_range_test.c:57:1: note: in expansion of macro ‘TEST’
    57 | TEST(close_range)
    | ^~~~
    In file included from /usr/include/unistd.h:1204,
    from close_range_test.c:13:
    /usr/include/x86_64-linux-gnu/bits/unistd_ext.h:56:12: note: previous declaration of ‘close_range’ with type ‘int(unsigned int, unsigned int, int)’
    56 | extern int close_range (unsigned int __fd, unsigned int __max_fd,
    | ^~~~~~~~~~~

    Signed-off-by: Shuah Khan <skhan@linuxfoundation.org>
    Signed-off-by: Sasha Levin <sashal@kernel.org>
    ---
    tools/testing/selftests/core/close_range_test.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/tools/testing/selftests/core/close_range_test.c b/tools/testing/selftests/core/close_range_test.c
    index 73eb29c916d1b..aa7d13d91963f 100644
    --- a/tools/testing/selftests/core/close_range_test.c
    +++ b/tools/testing/selftests/core/close_range_test.c
    @@ -54,7 +54,7 @@ static inline int sys_close_range(unsigned int fd, unsigned int max_fd,
    #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
    #endif

    -TEST(close_range)
    +TEST(core_close_range)
    {
    int i, ret;
    int open_fds[101];
    --
    2.33.0


    \
     
     \ /
      Last update: 2021-11-16 00:10    [W:4.033 / U:0.064 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site