Messages in this thread |  | | Subject | Re: [PATCH v9 2/2] x86/sgx: Add an attribute for the amount of SGX memory in a NUMA node | From | Jarkko Sakkinen <> | Date | Mon, 01 Nov 2021 02:01:37 +0200 |
| |
On Sun, 2021-10-31 at 19:49 +0200, Jarkko Sakkinen wrote: > On Fri, 2021-10-29 at 10:00 -0700, Dave Hansen wrote: > > On 10/29/21 5:18 AM, Jarkko Sakkinen wrote: > > > +What: /sys/devices/system/node/nodeX/sgx/size > > > +Date: October 2021 > > > +Contact: Jarkko Sakkinen <jarkko@kernel.org> > > > > I don't think we should do something *entirely* SGX-specific here. The > > only question to me is whether any non-SGX users want something like > > this and who they are. > > > > Here are some ideas I like more than an "sgx/" directory: > > > > /sys/devices/system/node/nodeX/arch/sgx_size > > /sys/devices/system/node/nodeX/x86/sgx_size > > /sys/devices/system/node/nodeX/coco/sgx_size > > Sure, I can rename the attribute group as "x86".
Dave,
So, if I rename sgx_node_group as arch_node_dev_group, we also need something like CONFIG_ARCH_HAS_NODE_DEV_GROUP defined in arch/Kconfig, so that the group definition in drivers/base/node.c becomes:
static const struct attribute_group *node_dev_groups[] = { &node_dev_group, #ifdef CONFIG_ARCH_HAS_NODE_DEV_GROUP &arch_node_dev_group, #endif NULL, }
Does this make sense to you, and reflect your feedback in a reasonable manner?
/Jarkko
|  |