lkml.org 
[lkml]   [2021]   [Oct]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v3 0/2] Add a generic virtual thermal sensor
Date
This series add a virtual thermal sensor.
It could be used to get a temperature using some thermal sensors.
Currently, the supported operations are max, min and avg.
The virtual sensor could be easily extended to support others operations.

Changes in v2:
- Fix some warnings / errors reported by kernel test robot
- rename some struct and functions with a more accurate name
- update the dt bindings: rename type attribute to aggregation-function
- factorize a little bit the aggregation functions
Changes in v3:
- Aggregate thermal zone instead of thermal sensors
- Use try_get_module / put_module to prevent thermal providers to be removed
- Update the bindings, to be more accurate

Alexandre Bailon (2):
dt-bindings: Add DT bindings for the DT-based virtual sensor driver
thermal: add a virtual sensor to aggregate temperatures

.../thermal/virtual,thermal-sensor.yaml | 80 +++++++
drivers/thermal/Kconfig | 8 +
drivers/thermal/Makefile | 1 +
drivers/thermal/virtual_thermal_sensor.c | 219 ++++++++++++++++++
include/dt-bindings/thermal/virtual-sensor.h | 15 ++
5 files changed, 323 insertions(+)
create mode 100644 Documentation/devicetree/bindings/thermal/virtual,thermal-sensor.yaml
create mode 100644 drivers/thermal/virtual_thermal_sensor.c
create mode 100644 include/dt-bindings/thermal/virtual-sensor.h

--
2.32.0

\
 
 \ /
  Last update: 2021-10-29 17:10    [W:0.046 / U:0.168 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site