lkml.org 
[lkml]   [2021]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] staging: rtl8712: remove the condition with no effect
From
On 10/28/21 07:31, Saurav Girepunje wrote:
> Remove the if condition check and else code section in
> query_rx_phy_status(). As variable cck_highpwr is assign a value of '0'
> after this assignment, if condition check !cck_highpwr is always
> going to be true. So remove the if condition check as well as else
> section which will be never true.
>
> After removing the if condition there is no use of local variable
> cck_highpwr. Remove the local variable cck_highpwr.
>
> Signed-off-by: Saurav Girepunje <saurav.girepunje@gmail.com>
> ---

[code snip]

> + report = pcck_buf->cck_agc_rpt & 0xc0;
> + report >>= 6;
> + switch (report) {
> + /* Modify the RF RNA gain value to -40, -20,
> + * -2, 14 by Jenyu's suggestion
> + * Note: different RF with the different
> + * RNA gain.
> + */
> + case 0x3:
> + rx_pwr_all = -40 - (pcck_buf->cck_agc_rpt &
> + 0x3e);

You can move "0x3e);" part on previous line, since it will fit even 80
characters boundary. It will improve readability, IMO

Same below.

> + break;
> + case 0x2:
> + rx_pwr_all = -20 - (pcck_buf->cck_agc_rpt &
> + 0x3e);
> + break;
> + case 0x1:
> + rx_pwr_all = -2 - (pcck_buf->cck_agc_rpt &
> + 0x3e);
> + break;
> + case 0x0:
> + rx_pwr_all = 14 - (pcck_buf->cck_agc_rpt &
> + 0x3e);
> + break;
> }
> +



With regards,
Pavel Skripkin

\
 
 \ /
  Last update: 2021-10-28 13:27    [W:0.049 / U:0.652 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site