lkml.org 
[lkml]   [2021]   [Oct]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] kernel/params.c: Refactor dash2underscore
On Sat, Oct 23, 2021 at 08:04:51PM +0200, Jim Christian Haukvik wrote:
> This patch refactors the dash2underscore function
> to use the ternary operator.
>
> Signed-off-by: Jim Christian Haukvik <jchaukvik@gmail.com>
> ---
> kernel/params.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/kernel/params.c b/kernel/params.c
> index 8299bd764e42..865a76fec79a 100644
> --- a/kernel/params.c
> +++ b/kernel/params.c
> @@ -76,9 +76,7 @@ static void maybe_kfree_parameter(void *param)
>
> static char dash2underscore(char c)
> {
> - if (c == '-')
> - return '_';
> - return c;
> + return (c == '-') ? '_' : c;
> }

This is not an improvement. You're just making the code harder to read
for no good reason (the ternary operator tends to do so).

Johan

\
 
 \ /
  Last update: 2021-10-24 12:40    [W:0.097 / U:1.716 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site