lkml.org 
[lkml]   [2021]   [Oct]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v6 2/2] pinctrl: microchip sgpio: use reset driver
From
Date
Hi Horatiu,

On Mon, 2021-10-18 at 10:57 +0200, Horatiu Vultur wrote:
> On lan966x platform when the switch gets reseted then also the sgpio
> gets reseted. The fix for this is to extend also the sgpio driver to
> call the reset driver which will be reseted only once by the first
> driver that is probed.
>
> Signed-off-by: Horatiu Vultur <horatiu.vultur@microchip.com>
> ---
> drivers/pinctrl/pinctrl-microchip-sgpio.c | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/drivers/pinctrl/pinctrl-microchip-sgpio.c b/drivers/pinctrl/pinctrl-microchip-sgpio.c
> index 072bccdea2a5..78765faa245a 100644
> --- a/drivers/pinctrl/pinctrl-microchip-sgpio.c
> +++ b/drivers/pinctrl/pinctrl-microchip-sgpio.c
> @@ -17,6 +17,7 @@
> #include <linux/pinctrl/pinmux.h>
> #include <linux/platform_device.h>
> #include <linux/property.h>
> +#include <linux/reset.h>
>
> #include "core.h"
> #include "pinconf.h"
> @@ -803,6 +804,7 @@ static int microchip_sgpio_probe(struct platform_device *pdev)
> int div_clock = 0, ret, port, i, nbanks;
> struct device *dev = &pdev->dev;
> struct fwnode_handle *fwnode;
> + struct reset_control *reset;
> struct sgpio_priv *priv;
> struct clk *clk;
> u32 val;
> @@ -813,6 +815,11 @@ static int microchip_sgpio_probe(struct platform_device *pdev)
>
> priv->dev = dev;
>
> + reset = devm_reset_control_get_optional_shared(&pdev->dev, "switch");

This is the first GPIO driver that I am aware of that requests a named
reset control, so I'm still not sure if this should be called "switch"
instead of "gpio" or just "reset", just in case there is a future model
where the GPIO controller reset is not shared with the switch reset.

> + if (IS_ERR(reset))
> + return dev_err_probe(dev, PTR_ERR(reset), "Failed to get reset\n");
> + reset_control_reset(reset);
> +
> clk = devm_clk_get(dev, NULL);
> if (IS_ERR(clk))
> return dev_err_probe(dev, PTR_ERR(clk), "Failed to get clock\n");

But whichever name you choose, the code is

Reviewed-by: Philipp Zabel <p.zabel@pengutronix.de>

regards
Philipp

\
 
 \ /
  Last update: 2021-10-18 12:37    [W:0.238 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site