lkml.org 
[lkml]   [2021]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH -next] mmc: core: use roundup macro to to calculate blk_sz
On Tue, 22 Dec 2020 at 14:34, Zheng Yongjun <zhengyongjun3@huawei.com> wrote:
>
> Don't open-code roundup() kernel macro.
>
> Signed-off-by: Zheng Yongjun <zhengyongjun3@huawei.com>
> ---
> drivers/mmc/core/sdio_io.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/mmc/core/sdio_io.c b/drivers/mmc/core/sdio_io.c
> index 79dbf90216b5..35c69bdeb40e 100644
> --- a/drivers/mmc/core/sdio_io.c
> +++ b/drivers/mmc/core/sdio_io.c
> @@ -263,8 +263,7 @@ unsigned int sdio_align_size(struct sdio_func *func, unsigned int sz)
> * Realign it so that it can be done with one request,
> * and recheck if the controller still likes it.
> */
> - blk_sz = ((sz + func->cur_blksize - 1) /
> - func->cur_blksize) * func->cur_blksize;
> + blk_sz = roundup(sz, func->cur_blksize);

If I understand correctly, roundup() assumes func->cur_blksize is a
power of 2. The above doesn't, which means there is no open coding
happening here.

> blk_sz = _sdio_align_size(blk_sz);
>
> /*
> --
> 2.22.0
>

Kind regards
Uffe

\
 
 \ /
  Last update: 2021-01-19 14:31    [W:0.043 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site