lkml.org 
[lkml]   [2020]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] i2c: Switch to using the new API kobj_to_dev()
From
Date


在 2020/9/19 5:09, wsa@kernel.org 写道:
>
>> static inline struct i2c_client *kobj_to_i2c_client(struct kobject *kobj)
>> {
>> - struct device * const dev = container_of(kobj, struct device, kobj);
>> + struct device * const dev = kobj_to_dev(kobj);
>> return to_i2c_client(dev);
>
> Can't we make this a oneliner then merging the last two lines?
>
I think two lines have better readability, and if you prefer one line, I
can send v2 to fix that!

\
 
 \ /
  Last update: 2020-09-19 03:02    [W:0.067 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site