lkml.org 
[lkml]   [2020]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH -next] fs: Fix 'mnt' kernel-doc warning in namespace.c
    Date
    Fixes the following W=1 kernel build warning(s):

    fs/namespace.c:1358: warning: Excess function parameter 'mnt' description in 'may_umount_tree'

    Rename mnt to m.

    Reported-by: Hulk Robot <hulkci@huawei.com>
    Signed-off-by: Wang Hai <wanghai38@huawei.com>
    ---
    fs/namespace.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/fs/namespace.c b/fs/namespace.c
    index 098f981dce5..9f9a2664dd7 100644
    --- a/fs/namespace.c
    +++ b/fs/namespace.c
    @@ -1358,7 +1358,7 @@ void mnt_cursor_del(struct mnt_namespace *ns, struct mount *cursor)

    /**
    * may_umount_tree - check if a mount tree is busy
    - * @mnt: root of mount tree
    + * @m: root of mount tree
    *
    * This is called to check if a tree of mounts has any
    * open files, pwds, chroots or sub mounts that are
    --
    2.17.1
    \
     
     \ /
      Last update: 2020-09-11 14:34    [W:4.214 / U:0.480 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site