lkml.org 
[lkml]   [2020]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH drm/hisilicon v2 3/3] drm/hisilicon: Rename variables to represent the correct meaning
Date
Rename plane to primary_plane in the structure hibmc_drm_private.
so it's clear which plane it represents.

Signed-off-by: Tian Tao <tiantao6@hisilicon.com>
---
drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c | 2 +-
drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c
index af24c72..d9062a3 100644
--- a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c
+++ b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c
@@ -504,7 +504,7 @@ int hibmc_de_init(struct hibmc_drm_private *priv)
{
struct drm_device *dev = priv->dev;
struct drm_crtc *crtc = &priv->crtc;
- struct drm_plane *plane = &priv->plane;
+ struct drm_plane *plane = &priv->primary_plane;
int ret;

ret = drm_universal_plane_init(dev, plane, 1, &hibmc_plane_funcs,
diff --git a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h
index 91ef15c..197485e 100644
--- a/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h
+++ b/drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h
@@ -28,7 +28,7 @@ struct hibmc_drm_private {

/* drm */
struct drm_device *dev;
- struct drm_plane plane;
+ struct drm_plane primary_plane;
struct drm_crtc crtc;
struct drm_encoder encoder;
struct drm_connector connector;
--
2.7.4
\
 
 \ /
  Last update: 2020-08-03 02:41    [W:0.486 / U:2.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site