lkml.org 
[lkml]   [2020]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v3 05/11] KVM: SVM: Modify 64 bit intercept field to two 32 bit vectors
On Tue, Jul 28, 2020 at 4:38 PM Babu Moger <babu.moger@amd.com> wrote:
>
> Convert all the intercepts to one array of 32 bit vectors in
> vmcb_control_area. This makes it easy for future intercept vector
> additions. Also update trace functions.
>
> Signed-off-by: Babu Moger <babu.moger@amd.com>
> ---

> @@ -128,8 +129,7 @@ enum {
>
> struct __attribute__ ((__packed__)) vmcb_control_area {
> u32 intercepts[MAX_VECTORS];
> - u64 intercept;
> - u8 reserved_1[40];
> + u8 reserved_1[60 - (MAX_VECTORS * 4)];

Perhaps this could be simplified to 'u32 reserved_1[15 - MAX_VECTORS];'

> u16 pause_filter_thresh;
> u16 pause_filter_count;
> u64 iopm_base_pa;

Reviewed-by: Jim Mattson <jmattson@google.com>

\
 
 \ /
  Last update: 2020-07-29 23:07    [W:0.175 / U:0.620 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site