lkml.org 
[lkml]   [2020]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 5/9] mfd: mt6360: Rename mt6360_pmu_data by mt6360_data
On Fri, 17 Jul 2020, Gene Chen wrote:

> From: Gene Chen <gene_chen@richtek.com>
>
> Rename mt6360_pmu_data by mt6360_data because of including
> not only PMU part, but also entire MT6360 IC.
>
> Signed-off-by: Gene Chen <gene_chen@richtek.com>
> ---
> drivers/mfd/mt6360-core.c | 44 ++++++++++++++++++++++----------------------
> include/linux/mfd/mt6360.h | 2 +-
> 2 files changed, 23 insertions(+), 23 deletions(-)
>
> diff --git a/drivers/mfd/mt6360-core.c b/drivers/mfd/mt6360-core.c
> index 665e26f..62bae1a 100644
> --- a/drivers/mfd/mt6360-core.c
> +++ b/drivers/mfd/mt6360-core.c
> @@ -210,9 +210,9 @@ static const struct regmap_irq mt6360_pmu_irqs[] = {
>
> static int mt6360_pmu_handle_post_irq(void *irq_drv_data)
> {
> - struct mt6360_pmu_data *mpd = irq_drv_data;
> + struct mt6360_data *data = irq_drv_data;

'data' is a terrible variable name.

Could you rename this 'ddata' please?

[...]

> -struct mt6360_pmu_data {
> +struct mt6360_data {

Same here, 'mt6360_ddata'.

Once you make these changes, you can add my:

For my own reference (apply this as-is to your sign-off block):

Acked-for-MFD-by: Lee Jones <lee.jones@linaro.org>

--
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog

\
 
 \ /
  Last update: 2020-07-27 14:07    [W:0.262 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site