lkml.org 
[lkml]   [2020]   [Jul]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH RFC V2 13/17] kmap: Add stray write protection for device pages
    On Fri, Jul 17, 2020 at 11:21:39AM +0200, Peter Zijlstra wrote:
    > On Fri, Jul 17, 2020 at 12:20:52AM -0700, ira.weiny@intel.com wrote:
    > > @@ -31,6 +32,20 @@ static inline void invalidate_kernel_vmap_range(void *vaddr, int size)
    > >
    > > #include <asm/kmap_types.h>
    > >
    > > +static inline void enable_access(struct page *page)
    > > +{
    > > + if (!page_is_access_protected(page))
    > > + return;
    > > + dev_access_enable();
    > > +}
    > > +
    > > +static inline void disable_access(struct page *page)
    > > +{
    > > + if (!page_is_access_protected(page))
    > > + return;
    > > + dev_access_disable();
    > > +}
    >
    > These are some very generic names, do we want them to be a little more
    > specific?

    I had them named kmap_* but Dave (I think it was Dave) thought they did not
    really apply strictly to kmap_*.

    They are static to this file which I thought may be sufficient to 'uniqify'
    them?

    I'm ok to change them but that is how I arrived at this name.

    Ira

    \
     
     \ /
      Last update: 2020-07-19 06:14    [W:3.299 / U:0.300 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site