lkml.org 
[lkml]   [2020]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 13/25] Documentation: watch_queue.rst: fix sphinx warnings
From
Date
On 7/17/20 11:56 AM, Daniel W. S. Almeida wrote:
> From: "Daniel W. S. Almeida" <dwlsalmeida@gmail.com>
>
> Fix the following warnings:
>
> watch_queue.rst:107: WARNING: Inline literal start-string
> without end-string.
>
> watch_queue.rst:107: WARNING: Inline emphasis start-string
> without end-string
>
> watch_queue.rst:184: WARNING: Inline literal start-string
> without end-string.
>
> watch_queue.rst:184: WARNING: Inline emphasis start-string
> without end-string
>
> Signed-off-by: Daniel W. S. Almeida <dwlsalmeida@gmail.com>
> ---
> Documentation/watch_queue.rst | 9 ++++-----
> 1 file changed, 4 insertions(+), 5 deletions(-)
>
> diff --git a/Documentation/watch_queue.rst b/Documentation/watch_queue.rst
> index 849fad6893efa..4c3098b8fa947 100644
> --- a/Documentation/watch_queue.rst
> +++ b/Documentation/watch_queue.rst
> @@ -103,8 +103,7 @@ watch that specific key).
>
> To manage a watch list, the following functions are provided:
>
> - * ``void init_watch_list(struct watch_list *wlist,
> - void (*release_watch)(struct watch *wlist));``
> + * ``void init_watch_list(struct watch_list *wlist, void (*release_watch)(struct watch *wlist));``
>
> Initialise a watch list. If ``release_watch`` is not NULL, then this
> indicates a function that should be called when the watch_list object is
> @@ -179,9 +178,9 @@ The following functions are provided to manage watches:
> driver-settable fields in the watch struct must have been set before this
> is called.
>
> - * ``int remove_watch_from_object(struct watch_list *wlist,
> - struct watch_queue *wqueue,
> - u64 id, false);``
> + * ``int remove_watch_from_object(struct watch_list *wlist,``
> + ``struct watch_queue *wqueue,``
> + ``u64 id, false);``
>
> Remove a watch from a watch list, where the watch must match the specified
> watch queue (``wqueue``) and object identifier (``id``). A notification
>

Wow. If that's what it takes, well, OK, but it's sad IMHO.

--
~Randy

\
 
 \ /
  Last update: 2020-07-17 21:44    [W:0.350 / U:0.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site